Shadow Intersection looking bad

Hello devforumers!

So I am trying to build an office building and I found some good Lighting Settings I can use but I have encountered a problem when turning on the SpotLight’s Shadows. For some reason these Intersecting Shadows. Now I tried to turn off CastShadow but then the furniture looks “displaced” (2nd picture). I have tried to turn off some Shadows from the SpotLights property, but the furniture still looks bad then. ShadowSoftness from Lighting Service doesn’t help too. So is there anyway to make the Shadows not intersect, or at least not look bad?

Any help appreciated!

With Shadows:

No Shadows (CastShadow for BaseParts are off)

SpotLight Settings, if needed


Try using a surface light with the angle and range maxed out.

1 Like

I completely forgot about surface lights.

This helped me out, the shadows looked more “sharp” making it easier to tell which part and light I can turn off CastShadow and it looks very nice. Thanks!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.