Shadows do not appear for the client, but they do for the server and studio

Hello, I’m having an issue which I have spent a good while trying to fix to no avail. It’s simple - no shadows appear on the client side of my game, but they appear in studio and on the server side of the game. The images below are taken from the client and server side respectively:

Other general information:
–I am not sure when the issue first appeared, but it seems to line up with when I added a large, part-dense map to the game, so there’s a chance it’s linked to that.
–However, removing these parts does not seem to fix the issue.
–Older copies of the game have working shadows for the client.
–In Lighting, Global shadows is enabled, and I have used all settings for technology, but none of these fix the issue.
–Playing the game on regular roblox as well as being on a different device does not fix it.
–My studio graphics and roblox graphics are set to the maximum. (21 And 10)
–The issue persisted even after I made a copy of the game.
–Brightness of the game is 2.3.
–Every part has CastShadow enabled, I did check for this on the client side.
–Time of day does not change anything.
–Even afterwards disabling every script the issue remains.


I fixed this after 2 months. For some reason, it had to do with an unrelated Over the shoulder camera script. I’m not sure why that was happening.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.