Shadows looking strange?

For some reason my shadows inside my game aren’t looking right, this issue occurs on Voxel and Compatibility.

i’d recommend turning off “CastShadow” on the Properties tab from this model in order to fix the issue.

You can try inserting a humanoid into the model. On Voxel lighting, this would force the model to have the more detailed character shadows. Don’t do it to every model in the game though, it could affect your game’s performance.


If you don’t want it to be a shadow, turn off the shadow feature.

Try modeling the tree. (it won’t solve the problem but) try to create a shadow by adding parts inside the leaves of the tree. :evergreen_tree:

You can try Going to file then press studio settings > rendering then change quality level into level 21

That worked but the shadow’s have lines now.

Make sure that the shadow feature of the trunk of the tree is turned on.

You can adjust the shadow size and direction by changing the clock in the Lightning section!