Shadows not working?

Hi there, I’ve currently been having this issue for a long time, I’ve looked past it for a while but now it just sticks out really and I’d like to get it fixed.

I took some photos showing the problem since it’s a bit hard to explain. I’ve tried fixing my graphics mode to highest and lowest as well as on studio, all shadows are on as well.

Not sure why this is happening but I know it’s not an uncommon issue.

1 Like

Usually the thickness of the part affects it. If the part is thicker that doesn’t happen. Have you tried turning on futuristic lighting?

1 Like

My lighting is already on Future lighting mode, I’ve tried with part thickness and it’s not really that well working because for the real effect you have to make it about 20 studs thick.

Let me mess with it and I’ll get back to you.

To be honest, I’m not sure. Hopefully someone else will reply who has found a fix for this.


simply just make the walls and ceiling thicker.

that is really the only fix I found so far.


yeah for sure lol. i just instead made the time of day to night and stuff.

Hey! There’s a few things that can be going on here, so lets go over them:

I: The thickness of your parts might be too slim, have you tried increasing them on the exterior of the build to not let light through?

II: If they’re mesh, it’s possible for light to come through try placing a part of the mesh to block off light.

III: try making your connections between walls also thicker.

IV: make sure cast shadows is on as well

Let me know if this helped and or you need more details