Shadows under tree unreasonably dark

Now I know everyone is thinking Ambient right now but the problem is I need my ambient value to stay at (0,0,0) because certain places which light can’t reach should be very dark. But how could I fix this tree and its poor grass getting little to absolutely no light? I’ve tried a lot of things and I don’t know what the problem is. Maybe I messed with the wrong values in lighting?

The tree picture

The lighting settings

1 Like

It would appear the main issue causing that extreme darkness would be the fact that the light from the sun is encountering several large solid objects - aka your leaves - making the below area incredibly dark, which is the same process the areas on your map that are supposed to be dark would undergo.
One more simple solution would be to just disable the Cast Shadow property on some of your leaves, depending on what you want the shadow to look like, ie. shape/darkness.
Without touching ambient I suppose you could always also turn up the exposure compensation if you wanted, or add in a color correction effect and try to play with the brightness settings there as well.


Rather go on one of the leaves’ part, and turn off ‘Cast Shadow’ rather than the whole model itself.

I think the reason the shadow is so dark is because you’re using shadowmap, which creates intense shadows. If you need to remove such intense shadows,

I would suggest:

  1. Turning off cast shadow for the entire tree. There’s currently a dark shadow because you have parts blocking the light from getting to below the tree.
  2. Turning off cast shadow for the leaves. Same thing as above but there’s still a shadow for the trunk.
  3. Adding a light below/in the tree. This way the light will make it look like sunlight’s passing through when it reality there’s just another light. Make sure to make the part invisible and change the color accordingly.

If none of the above solutions work, then you can also try these, but keep in mind they will change lighting in your entire world.

  1. Turn off shadowmap. This could make the shadows less extreme. Try Voxel or Compatibility instead.
  2. Turn up Exposure Compensation. This will lighting everywhere, though.
  3. Mess with Color Correction and try making the shadows a brighter hue.
  4. Play with brightness, if you want. But it will mess with brightness globally.
  5. If all else fails, just turn global shadows off. The caveat is that there’s no shadows anywhere. This should be a last resort.

If nothing still works:

  1. Just make your ambient brighter/whiter.

there’s a trick to keeping shadows while removing self-shadows that might be worth trying - put a humanoid object inside the tree model. it bugs out visually with alpha textures but should work here

1 Like