Shirts don't upload properly

I am uploading clothing for a NPC in one of my games, and also to wear for my website avatar, but whenever I upload a shirt (either through the create tab or through a group) instead of displaying the “N/A” sign or some sort of “in-moderation” symbol where the clothing visual appears, it just shows an empty Roblox character (with no shirt) and when I try to wear the shirt it doesn’t show up.


I’m pretty sure that it’s a glitch.


Are you using the proper template for creating the shirt? Have you tried uploading a different shirt, does the issue still happen? Have you tried re-uploading your shirt again?

If you have tried all of these things and you are still having the same issue you can make a bug report for it in the #platform-feedback:web-bugs category. As you are a new member you will have to go through the post approval process to post there. Make sure you provide as much information as possible.

I think it might be a glitch that shirts doesn’t show up, but it should work when you try it on the game unless it’s moderated, of course.

What in-moderation symbol are you referring to? Could you send a screenshot of that here?

I’ve encountered this problem multiple times too myself. I can confirm that it is NOT another way for showing the “moderation” status, as it is still there when verified by the moderators.

Yes and I’ve uploaded over 100 shirts in the past that didn’t do this

I’ll post there ty

when you upload a shirt it shows a paper with an hour glass which means your item is awaiting approval

i haven’t uploaded something in a while and i’m not sure if this is how it is currently

1 Like

I have the same problem too and it’s kinda upsetting me.