Shirts, Pants, and Body Colors Not Displaying

  1. What do you want to achieve? Keep it simple and clear!

I want shirts & pants to display properly on my character.

  1. What is the issue? Include screenshots / videos if possible!

Very often, body colors, shirts or pants will not load onto my character, despite containing valid IDs. They will occasionally load for other players on their respective clients. Here’s a video of this issue.

  1. What solutions have you tried so far? Did you look for solutions on the Developer Hub?

Our game uses a script to add custom characters, such as shirts, pants, body colors, and mesh parts, to the character when spawned. These items are located in folders inside Server Storage.

local function SetDisplayChar(Character,VisualCharacter)
    for ind,data in next,VisualCharacter:GetChildren() do
        local NewData = data:Clone()
        local Weld = NewData:FindFirstChildOfClass("Weld")
        if Weld then
            Weld.Part0 = NewData
            Weld.Part1 = Character:FindFirstChild(Weld.Name)

        NewData.Parent = Character

Initially, we had thought that our script was the cause of this issue, but no matter how many changes we would make to this script, our characters would remain completely grey.

This issue would occur less inside of playtesting, however it remains persistent outside of it. Dummies also seem to have no issue loading shirts and pants.

We are using a R6 starter character, and LoadCharacter() is utilized to spawn characters. This issue has occurred very recently, and I am unsure of how to fix it.

1 Like

I’m getting reports of this problem starting two days ago. I initially thought it was network related but I haven’t seen any asset loading errors in the console. My game uses R15 only.

This also happens to classic faces as well. Which results in blank character heads.

My system creates Shirts, Pants, classic faces and parents them into the character and that’s been working fine up until then. May be specific to this behavior.

Me and Swufin have been at work trying to find a fix/workaround but have been unsuccessful.

We tried alot of methods of putting clothing onto the user and they have all given the same result seen in the video.

Methods such as using/creating humanoid descriptions for applying them,
cloning and parenting them,
creating new ones and parenting them,
replacing pre-existing clothing.

All those methods has failed to work and sometimes given the R6 rig a big head that’s unalterable.
Workspace.AvatarUnificationMode is set to Disabled btw.

I have not made any changes on my end and the issue came up suddenly. Assuming your setup has a proper Humanoid configuration and still won’t work, this seems like a engine bug more than anything.

The issue for us also suddenly started happening which is very odd,

2 days ago it was working completely fine with the cloning method and then it just suddenly stopped rendering the clothing while we were working on the game.

And we do have a proper setups for our characters & their humanoids, so I also believe its a engine bug, hope it gets looked into & fixed soon.

You may want to post this issue under engine bugs then so engineers can see the issue quicker.