Skinned Mesh is scaled weirdly on certain players screens

Reproduction Steps
Game Link: [🌊TRADE] All Star Tower Defense - Roblox

One of the characters who sits on player’s shoulders has a skinned part tail with bones and for certain players the tail is longer then it should be. This glitch seems to happen on select players devices [for me I don’t view it, but for other people in my server they may so happen to see the glitch].

Expected Behavior
Screen Shot 2021-09-30 at 1.59.30 PM

Actual Behavior
Screen Shot 2021-09-30 at 2.16.39 PM

Workaround
When in a server deleting any of the bones in the tail through console seems to fix the problem for that specific tail

Issue Area: Engine
Issue Type: Display
Impact: Moderate
Frequency: Sometimes
Date First Experienced: 2021-09-29 22:09:00 (-04:00)
Date Last Experienced: 2021-09-30 00:09:00 (-04:00)

1 Like

There seems to be a shadow update on the skinned mesh that breaks the animation in random servers and new fresh servers. I have a similar issue at the moment that the skinned mesh is squished together like this. They were fine a couple of days ago, and I didn’t touch any of the animation systems in-game.

The bug appears to only happen on PC and is only happening on rigs with more than 1 part. This bug only happens on live server, and works completely fine in Studio. It only happens for players with humanoid.

unknown (2)

@FruitySama, your place should be returning to normal shortly, but we would like to reproduce what happened. In Studio, if you turn on Cage Mesh Deformer Beta, can you reproduce the problem there?

@nakata1609 what place(s) are showing this issue?

This place: [🔥CHAOS X] Digimon Masters - Roblox

The bug happens on some server especially fresh new one. A new private server have a higher chance of getting it.

@nakata1609, the problem should go away shortly. Also, same question for you, if you turn on Cage Mesh Deformer Beta in Studio, can you reproduce the problem there?

1 Like

Yes, the issue still persist whether it is ON or OFF. This is the expectation (studio) vs live result. Noticed how the model are squished to the center.


The issues in live places should go away shortly, let us know if it doesn’t. The Studio Beta setting won’t impact live places.

But if possible, even when the live game returns to normal, we would still like to reproduce the broken state in Studio if possible, so we can debug exactly what is happening and make sure it doesn’t happen again. We are hoping that turning on Cage Mesh Deformer Beta will allow you to recreate the broken state in Studio?

2 Likes

I actually did some testing on switching it On and off on a test game, and the squished issue still persist. However, there is a different bug when I turned on the cage mesh deformed and this bug only appears on Studio.

With the deformed ON, the rig with multiple parts only has (50% chance) ONE of their parts animated (bones are still moving), while when it is OFF, every part is moving like normal. With the deformed ON, it is impossible to edit complex skinned mesh after resizing in animation edit, so I had to turn them off every time I want to edit.

I will try my best to replicate the same bug on Studio. I also have an issue in Studio that one of my draft script is stuck in draft forever, and there is no way of discarding it.

Thanks for your help, let me know what you find.

So with the deformer ON, it seems like I got that result. One thing to noticed, the bug do not happens on NPC with humanoid (AI) or animated NPC with no humanoid. It only happens for players on rig with more than 1 part. Parts are welded together via WeldConstraint as well. Deformed ON → TOP, Deformed OFF - BOT


This is helpful, thanks, I will follow up with you in a private message.

1 Like

The same bug returned for some reason

Same its still happening to me

In the same places? I’m looking into it, thanks for your patience.

Sorry for the hiccup, should be returning to normal again, again.

1 Like

Hi, I PM’d you about a similar problem my team is experiencing. It looks like ours is directly related to the Cage Mesh Deformer Beta.

1 Like

Seems like the bug has returned…again…

We are investigating, thanks for your patience.

1 Like

Sorry for the disruption, everything should be working again now, please let us know if it isn’t.

When the bug was happening, was it happening for all players on Windows? Or only to players that teleported into the experience? Thanks for the info.

Hey all, we are trying to understand why this bug was happening again on “Digimon Masters” last week, when we had not enabled the flags on that particular place.

There are some possible explanations, the simplest one is that the bug was not happening here:

but on a different experience. For example, a development version of the same place that has a different place id.

Another possibility is that users joined a different experience, but then teleported from that experience into “Digimon Masters”.

Could you confirm if any of these could explain why the problem returned again?