Skinned meshes under character makes the character disappear while outside of viewport

Reproduction Steps
reproduction file found in private note

Move your camera so you can’t see any of the skinned meshes that are in the character, and the character + all descendants should disappear.
(does not happen in studio on Mac)

Expected Behavior
I would expect the character to not disappear when the skinned meshes are outside of the viewport

Actual Behavior
Everything under the character model disappears when the skinned meshes are outside of the viewport:

eee903a25016a6f732f3e3f37c9b31fb

Workaround
Only workaround is setting the transparency of the skinned mesh to 1, but then you cant see the mesh so its counter-productive;

Issue Area: Engine
Issue Type: Other
Impact: High
Frequency: Constantly
A private message is associated with this bug report

3 Likes

Check if you have the Cage Mesh Deformer enabled. I’ve had some issues with it lately that might be similar.

If this caused by the Cage Mesh Deformer Beta, please let us know.

No this is not, (I’m the person in that video above displaying the bug). This seems to be an issue for any type of skinned mesh under the character that is out of view for the camera. The weird issue is that if I go on the server and I also get the skinned mesh to not be within my camera view, it makes the character disappear. So this seems to be a bug internally, not sure.

1 Like

No we did not have cage mesh enabled, there are no beta features enabled

Someone else had this problem with an attack on titan giant. I believe your HRP is too big. This is the part that determines whether the humanoid is displayed. Shrink it, keep it in the middle of the body, and it reduces the angles where your model disappears.

The HRP is the size of a normal player … and from the description that sounds more like a hacky method to do it (would require me to change quite a bit of stuff around with rigging). I hope they can fix this fast.

You might want to try resizing the hrp just to confirm the cause at least. I am able do that without breaking the rest of the skinned mesh. The avatar importer hands me a part that is (2,2,2) and I switch it to (.2,.2,.2).

My issue is not disappearing, my issue is walking over small bumps in the floor with a skinned mesh. I think it would help you as well.

Any ETA on when this will be fixed?

The issue of rigid Parts disappearing when in the same Model as skinned MeshParts is fixed behind the FFlagSkinUseSkeletonAPI4 flag.
The flag is already on for LayeredClothing opt in, and Facial Animation Beta.

I can’t say when the flag will be on globally - but hopefully soon.

2 Likes