Skinned meshparts lagging a lot only when editing

Hey, so I’ve been working on skinned meshpart characters, and recently, my roblox studio has updated, and we can now see the bones out of the animation editor

Sadly, this update has brought an enormous amount of lag when I’m editing the game (I get about 18 fps), but when I test i, I get 60 fps, just like i did before, before the update.

I think I’ve seen a similar post earlier, but I can’t find it anymore.

I’m an animator and it is crucial for me to have good viewport performance so I can see it very clearly.
I would be very grateful for your help.


If you can’t see certain parts of your mesh from some angles, add a soldify modifier and set it to like 0.02+. consider also adding a decimate modifier and setting it to pretty high, I’ve experimented with this and your mesh might look terrible in the blender viewport, but it will look significantly better in roblox because of the way roblox’s shading system works. If none of that works, consider optimizing scripts and builds and removing free models that have crappy scripts and use a virus scanner plugin.

No thats not the point, i just have to turn on double-sided if i want to see both sides of the mesh (my mesh looks fine from the outside). The problem is the lag, and that it’s related to the visibility of the armature somehow. It’s the lag i want to fix. Thanks anyways!

P.S. solidify modifier doubles the tri count so no thx.

1 Like