Skinnedmesh PrimaryPart named "HumanoidRootPart" causes root bone to move incorrectly

After helping someone debug an animation issue, I found out that for some reason, the root bone was transforming x -2.5 of what the position values were supposed to be, while the orientation was totally fine. I was very perplexed.

RootBone target transform:

Result of reading the bone being animated:


I simply could not figure out what was causing this issue as the animator editor was totally fine while the played animation was incorrect. After eliminating every single possibility, the only way it actually worked again was when I renamed the primarypart from “HumanoidRootPart” to something else.

I have no clue why on earth this is the case, but here is a before and after of some animation issues that were fixed when renaming the primarypart from

Before (primary part is called HumanoidRootPart):

After (renamed primary part to something else on both model and the keyframes):

1 Like

hanks for the report! We’ll follow up when we have an update for you.

1 Like

Is this still not behaving how you expect? I fixed something related to this in December last year.