Slow speed body movers are bugging

Hi there,
I found, that when i set low speed (angular velocity <0.3) to body mover, it will stop move after about 1 sec. So, how can i solve it. Ok, i know, that i can create bug report, but with good luck, it will be repaired in 1 month (but some of my bug reports arent fixed after 3 months) and i need solution, that i can use rn.

Hey,

Did you increase the MaxTorque?

If that doesnt work, try setting a custom physical property to the brick, and making friction set to 0.

1 Like

This isnt the problem, when i set its speed to 0.3, it is working.

Did you try it?

Friction stops an object if there isn’t enough force being applied

Yes, it works, but i am making ship, so friction is needed to have good water level. BTW, the force is set to inf, and as i saied, with normal friction, it works as expected, but then it will stop for no reason.

Could you provide a video of the problem?

I have too slow internet, but just place part and add into it body mover, and when its speed is low, and friction is big, it will move and after some time, it will stop. At least for me.

You don’t need internet to record a video., You just need internet to send it.

Yes, but with my 50kb upload, it will be hard to upload it.

I played around with it, and even after setting friction to 0, maxtorque to inf and the P to a large number, it would always stop if the number was than 0.3. I suggest taking this to the bugs channel

it also depend on ressistant, so making it on water, it sometimes give suces, but i need to make it with heigher friction. My idea was to update its P ± 0,01, so it will not stop, but i think, this isnt good solution.

I am trying to find different solution, bec for example, this problem is making me mad


but nothing was fixed.

If you’re using a legacy bodymover have you tried increasing the P property?

Yes, but it just unlag for little moment and then fall back to lag (as when i do any other update).

I can replicate this problem, hopefully it’ll be fixed at some point. Even the AngularVelocity constraint has the same problem as the legacy BodyAngularVelocity.

I’ve found something that should work for you though!
CylindricalConstraint:

  • Set AngularActuatorType to Motor
  • Set AngularVelocity to your desired angular velocity
  • Set MotorMaxTorque to a very large number

If you set it up correctly (you’ll need 2 parts and 2 attachments) and set the properties to the values I’ve specified, then it should work as you’d like it to! Let me know if you want any more info or a demo model.

Regardless of this work-around, I see no reason why the body movers (legacy or new) should behave this way. This work-around is nowhere near as nice as a fix for this bug would be.

2 Likes

So i need to put there some part with fixed orientation and put there motor?
PS: I dont have my pc here, so i cant test it, but I found this problem also on servo, so idk if motor will be ok.

I just tested it agian and it didn’t seem to work unless I made the part bigger… This is definitely a bug and should be reported.

2 Likes

I solved it by script, that is updating P property.

This new update might fix the bug:

1 Like