(Solved) Accessory Falls Off When Parented To Character

Edit: Turns out parenting this way works fine via a script, it was just malfunctioning in studio.

As I read on Wiki, apparently attaching an Accessory to a character is as simple as putting an Attachment into the Handle that matches the name of a corresponding Attachment in the character.

When cloning my Accessory from ReplicatedStorage and parenting it directly to the R15 character the Accessory simply drops off. I had a similar issue with R6 but managed to hack my way around it but now I have no success. I don’t know if this is a glitch or something I’m doing wrong.

image

Maybe this is because it’s a Union not a Part?

It works fine if I Clone → Parent to Workspace → Parent to Character but parenting straight to character doesn’t work.

Doesn’t work when parenting from ReplicatedStorage:
https://i.gyazo.com/42f3418ba32243fe39c6da023d144a5c.mp4

Works when parenting from Workspace:
https://i.gyazo.com/7f856ca41fc5ac40324d334205d4730a.mp4

4 Likes