[SOLVED] Animation not playing properly

  1. What do you want to achieve? I want to have my animation playing how it supposed to be playing.

  2. What is the issue? When playing it in game, it does work but in a weird way

This is how it’s supposed to be
(solution found)

and that’s how it plays in game
(Solution found)

  1. What solutions have you tried so far? I’ve tried to look out topics but nothing helped.

This is my code


local plr = game.Players.LocalPlayer
local hum = plr.Character:FindFirstChild("Humanoid")

if hum then

local RightArm = plr.Character["Right Arm"]				
local Animator = hum:FindFirstChild("Animator")
local shootAnim = Instance.new("Animation")
shootAnim.Parent = RightArm

shootAnim.AnimationId = "rbxassetid://14432803618"
shootAnimTrack = Animator:LoadAnimation(shootAnim):Play()

Thanks, for reading.


Did you set the priority for the holding gun to Idle and when shooting to Action?

1 Like

Yes, I’ve also tried to set it to higher but nothing worked.

I’ve found the solution, and it’s to remove the default tool idle animation that’s by Roblox.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.