[Solved!] Default Tool Weld Causes Issue With Animated Tools

I’m having an issue with an idle animation for a gun system I’m using. The issue is as follows;
The regular roblox tool grip is overlapping with the idle animation. Yes it is looped, and the animation priority is set to Action.

Here is what I expected:

Here is what I got:

I can’t find any fixes for this, does anyone have an idea of how I would fix this?


Small suggestion, you might want to change the title of this to say “Default Tool Weld Causes Issue With Animated Tools”

Besides that, I’ve encountered this bug before and had to script a solution for it. What you need to do is use a name other than “Handle” for the handle and turn off RequiresHandle on your tool, then you need to add a Motor6D to that handle which I assume is similar to how you made the animation in the first picture. The C0 and C1 properties of that Motor6d need to be set to these:
C0 = CFrame.new(0, -1, 0, 1, 0, 0, 0, 0, 1, 0, -1, 0)
and the C1 needs to be set to the tool’s Grip property.
Alternatively, you can use the CFrame property of the “Left/RightGripAttachment” in your character’s arms.

At that point all you need to do is to create a script to set the Part0 of the Motor6D to the right or left arm when the tool is equipped.

In the end, this crazy solution looks like this.

This solution may work, but I am using a custom animation, and therefore I can’t see it’s likely for me to use a one arm attachment. Am I not understanding something?

This works fine with custom animations and allows you to animate the tool’s handle, which I’m guessing was the issue originally.

I might sound stupid, but does this weld the tool to the players arm, or only create a false weld so the tool can be animated with custom animations?

This welds the tool to the player’s arm while allowing tools to be animated with custom animations. It’s not a false weld as it is the weld.

There is another solution I should mention which might be easier to implement, and that’s to make the Handle invisible (pretty much creating a false handle for the humanoid to hold) and using a Motor6D to weld the real handle to the false one, allowing you to animate the tool.

(Had to repost since I accidentally replied to myself, oops.)

I’m gonna work on this tommorow because it’s like two AM and I havent slept for 22 hours, but I’ll update you if it works.

1 Like

This fix does not work for me, do you have any other ideas? (also this is kind of a bump i guess)

you should try parenting the tool to workspace, and keep the motor inside Right Arm

That would prevent the tool from working.

Why doesn’t it work may I ask?

Basically turn off requires handle like metioned above. And make sure when player equipes the tool you want and then motor6d constraint the PrimaryPart of the Tool to either the UpperTorso or Hand depending on what you looking for, make sure there is not part called handle in the tool aswell. Also when creating the animation make sure to create reset nodes for all of the body parts and weapon nodes that you don’t want to move during your animation

The tool still stays attached to the hand.

hihi there

Seems like you’re using FE Gun kit (can tell by the crosshair) if you haven’t seen the CustomGrip you should turn it on to let the script feature replace the weld to Motor6D, If the animation appears to be animated before rigging the gun, some animations won’t stay in place but lucky that there’s CustomGripCFrame to mess so you can re-position the motor6d without using Tool grip editor.

don’t forget to disable RequiresHandle

First of all, ty for replying (as I know you are a main contributer to FE Gun Kit Viewmodel)

Second, I have tried that, but I get an error when I try to shoot the gun, it is an error saying the Viewmodel Handle To Fire is nil, and I have changed the code (changing the modules to say the handlename, etc). Is there any fix to this?

Still looking for a solution, if anyone has an ideas please throw them in the pit

Hi, I got a new error. It is now welding the tool inside of the arm, should I change the CustomGripCFrame?

yes that’s where you have to modify the CFrame also like i said, disable RequiresHandle on the tool before letting the gun rigs to the body after enabling CustomGrip

When I do all of that, here is what happens. (Yes, I changed all the scripts to work with the guns custom handle)

External Media

And this is the error when I try to fire in the Viewmodel

Players.RealMysticall.Backpack.Five-Seven.GunClient:451: attempt to index nil with 'FindFirstChild'