[SOLVED] Movement increments rounding; creates tiny gaps

I’ve noticed that certain increments have been rounding a few more decimals which creates tiny gaps in my builds. I think that while the engine did previously round before, the values you entered were still the same - just visually rounded. I prefer using an increment that I divide in half every time (1, 0.5, 0.25, 0.125, 0.0625, 0.03125, etc.)

Unfortunately, anything smaller than or equal to 0.0625 gets rounded up (in this case it gets rounded to 0.063) which creates these very small gaps:
image

I’ve tried using plugins like Building Tools by F3X and manually setting the values, but these tiny gaps persist. If anyone knows a workaround for working with small increments, help would be much appreciated.
F3X works, I was mistaken.

UPDATE:
After testing the default move tool built into studio, I can now confirm that the move tool rounds the numbers then applies them to the object. Even more interestingly, manually setting the positions/sizes in the properties menu, despite visually rounding the number in the properties panel, sets the value to the actual input.

This can be seen here:

Part moved using move tool (Gap Present)

Part moved using properties panel (Gap Absent)

This is tedious manually setting the values - but it is a workaround.
Use F3X.

1 Like

That’s because moving an object is limited to three decimal places. You shouldn’t be needing to move something ten thousandths of a stud.

1 Like

I personally uncheck the studs count and eyeball it until it lines up somewhat neatly, on rare occasions I modify the position and size values in the properties tab.

I think this is something that will be there regardless of the increment value as far as I have noticed, I might be wrong.

Quick workaround is to right click the object and select “Align Dragged Objects”:

2 Likes

Is this increment rounding new? I’ve been using Studio for over 4 years and it seems like only recently it’s actually done anything. I remember it rounding values, but when I was actually building the engine seemed to just treat them as the actual input not the rounded number. Did something change?

I never had to use such small increments, the lowest I use is .125 so I wouldn’t know.

It used to work cleanly before (I use the same increments as OP), and 0.0625 used to move stuff 0.0625 studs, not 0.063. It’s annoying.

Yeah it’s been like this for a month or so, and it’s ruining my work in studio.
I HATE THIS.
image

1 Like

If you have to go that low, I recommend using 0.05 instead of 0.125

but I’ve been using these increments for years…