(SOLVED) Part's Textures are missing when the game runned | Building Support

Hello, i’m new to ROBLOX DevForum, I have a problem with my texture object, here is the detail:

I want to make a part with custom material, so i used texture object and put it inside my part

When the game runned, some textures object suddenly disappear.

An image showing the part is still having the texture object

An image showing the part lost 2 texture objects
This also happened when i run the game using “Play” button.

And what i tried to fix this is just swap the rotation of the part ( Left & Front texture is still exist )


Can you explain what really happened and how to fix it?

Thank you very much.
If you can’t understand what i said, feel free to ask it!


Only 4 part that have it’s textures missing, similiar to the image i sent.



My ROBLOX Studio is kinda bugged. I restarted and adding the texture back
After that, the problem fixed.

NOTE: This is my problem, if you have the similiar problem happened but this solution doesn’t work, try creating your own post and explain what you experienced and the problem itself.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.