[SOLVED] Players:GetUserThumbnailAsync acting weird

Hello. Currently, I’m making an game, and it needs to get user headshot. I made this code:

local plrs = game:GetService("Players")

local avatar = plrs:GetUserThumbnailAsync(plrs.LocalPlayer.UserId, Enum.ThumbnailType.HeadShot, Enum.ThumbnailSize.Size420x420)
script.Parent.Image = avatar

And… the result is REALLY weird.

Yes, Roblox Studio, this is definitely my avatar headshot. (Sarcasm, if that wasnt obvious)

Any thoughts how to fix this?

1 Like

Maybe ClipDescendants is messing with the image?

I tried to play with ImageRectOffset and ImageRectSize and it got better…
Maybe clipDescendats, i dont know. But changing the size made situation better

Is the image size exactly 420x420?


Seems like something is messing with the size of your image as showed in the picture.
Is there anything parented to the image such as UI constraints?

Yes. I deleted UI Constraint thing but nothing happen.
Also, i set imagerectoffset to 0,0 and my headshot became fine.
Thanks for the help!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.