[SOLVED] Translucent Blender to Roblox Import

I am trying to import a model I made on blender today.
Many parts keep appearing as translucent/see-through.
I have researched the subject thoroughly. I have checked the face directions, I have messed around with material properties, I have scoured every inch of the Developer Forum, YouTube, and Google.

(last image is a meme i know but it clearly shows the transparency better)

There is a couple of things that could be the issue. Backface culling could be the problem.

In Blender, look under material settings → preview and see if backface culling is checked. If it is, uncheck it and see if that fixes it.

1 Like

I have already checked and rechecked the blackface culling settings, as the only few solutions I found repeated again and again were the faces in the wrong direction, the alpha settings, and the blackface settings.

In studio, if you select your model and in properties check ‘double sided’ does that change anything?

1 Like

I’m under the impression that enabling double sided settings is unhelpful and dangerous considering it doubles the amount of lag (my models are already huge enough) and my faces are already in the right direction. I could try it but I highly doubt it would change a thing.

The only other thing I can think to try is to first save a backup of your file and then delete any material slots you have on the model and see if re-importing without it makes a difference.


Is this the setting you were talking about? For some reason it appears to have fixed the issue, which is strange because I’m 100% sure these faces aren’t negative.

(blue means not negative lol)

1 Like

Hmm… this makes me wonder if you have some duplicate faces in there. Have you done a clean-up and merged by distance on the faces? It could well be that your faces were oriented correctly, but there could be some rogue doubles in there that were causing it. Hard to say.

1 Like

I’ll be totally honest, I’m the type of person to jump into things like a wild animal and somehow come out the other end still alive. This is the first time I’ve used Blender properly in my life.

Ah, definitely check out documentation on ‘clean up’ and how it works. It can help a lot to get rid of loose parts, doubles and such.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.