Sound doesn't want to play

  1. What do you want to achieve? I want to make sure the sound is playing when the player clicks the tool

  2. What is the issue? The sound doesn’t want to play even though I requested it to

can’t provide video cuz of discourse limitations

  1. What solutions have you tried so far? I tried to look through the devforums, as well as trying to do some stuff

After that, you should include more details if you have any. Try to make your topic as descriptive as possible, so that it’s easier for people to help you!

Here is the error file

error file.rbxm

here is the code

local tool = script.Parent

local sound = tool:WaitForChild("PlaySound")


here is what it looks in the explorer


It’s name is correctly written in the script, It’s parented correctly, I don’t know why it’s not working, I have given sound permissions from the account used for the audio

Ohio Hide and Seek is the game I’m trying to put the sound in

1 Like

When using :WaitForChild() the string inside the bracket should be the same name as the sound in the explorer. Try changing it to tool:WaitForChild("Sound").

1 Like

Set the tool.RequiresHandle (in the properties window) to false since the tool doesn’t seem to have one


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.