Sound for MouseEnter not always playing

So I have this UI with buttons and whenever you hover your mouse over a button, a sound is played. However, it doesn’t play consistently at all; sometimes it plays, sometimes it doesn’t. Here’s a video to show what I mean:

I’ve tried stopping the sound before playing it, as well as using SoundService - nothing fixed it. I also sent @IceTaurus a repro file, and he had the same problem.

Sound Issue.rbxl (23.7 KB)

1 Like

As @Patrickblox said in the OP, I had the same issue. Both in server and on studio the bug occurs.

I’ve used print() before and after the sound is played, added a debounce for safe measures, and stopped the sound if it’s still playing on enter. Everything works perfectly fine, but the problem still persists.

Did some testing, found out your sound is the problem in general. I changed the sound id to something else and it works fine.

cc @spotco

Taking a look.

1 Like

It seems to be a problem with OGG file playback.
Converted the file to mp3 and everything worked as expected.
I’ll be taking a deeper investigation into this.


Just had a friend reupload them as MP3s, but both were rejected…

That’s unfortunate. Best I can tell you is just upload it again, slightly modified in audacity/program of your choice. I’ll send over an email and see if I can get an answer.

Yeah, well, the problem is that everytime I upload it as an .ogg file after modifying it in Audacity, this happens most of the time:

We’re recommending the mods always test files in VLC (there are some audio moderation tool problems that unfortunately aren’t getting fixed until some time next year), but it seems like problems are occurring.

Yes, I’ve unfortunately been unable to upload sound effects for the past couple of weeks as they get rejected most of the time. I hope you’ll look into this issue as well.