Sound not playing on :Play()

I made a bombing tool and the sound doesn’t work when I do Sound:Play()

Even Sound.Playing = true doesn’t make any difference. I have tested it by playing in the studio and by checking PlayOnRemove which works when the bomb is destroyed (but also when the player leaves or resets which I don’t want). If I play sound directly from the tool, it plays but then it will be in the tool instead of the clone in the workspace. Here’s my script. Any help is much appreciated!


local Tool = script.Parent
	local bom = Tool.Handle:Clone()
	bom.Parent = workspace
	bom.CanCollide = true
	bom.Part.CanCollide = true
	bom.Part1.CanCollide = true
	bom.Sound:Play() -- Soundis there when I check through explorer and plays if i play it manually.
	local exp ="Explosion",workspace)
	exp.ExplosionType = Enum.ExplosionType.NoCraters
	exp.BlastRadius = 25
	exp.DestroyJointRadiusPercent = 0
	exp.Position = bom.Position

I have searched forums but couldn’t find an answer. Sound works if I play manually before the bomb blasts.

do you have any output like an error message or something?

Maybe add another wait() after bom.Sound:Play(). I think you just destroy the bom part too early. just add a few seconds of delay.

It would be better if you do


So that it would wait until the sound has played finish before continuing with the rest of the script.

Oh yeah, it played for a bit, I found the problem, I’ll just anchor it and make it’s transparency 1 and wait till it ends.

I tried using this like this:

	if game.Lighting:GetMinutesAfterMidnight() == 3 * 60 then   

and it still doesn’t seem to work. Everything is correct I can’t get the sound to play.