Sound page shows a 404 when trying to access it

I uploaded an audio about 10 minutes ago and I tried finding it using my inventory. It was there:
However, clicking on it redirects to the 404 page on the Creator Hub:

Seemingly, the audio also cannot be found in the Inventory / Creations tabs in Studio’s Toolbox. The sound can be played and has passed moderation though. I uploaded this asset using Creator Hub’s “Development Items” tab, not using Studio.

Expected behavior

I expect to be able to access the page for my sound asset.

Page URL:


Hey @SomeFedoraGuy, thanks for reporting this! We’re investigating now, it looks like part of our upload pipeline has a lot of traffic right now and is slow. We’re working on getting things back to normal.

1 Like

Hey @SomeFedoraGuy, that audio asset may still take some time to show up, but could you try uploading a new audio asset as a workaround and let me know if that one still doesn’t show up?

Hey @leek_clee, I uploaded a new audio asset and that one does show up where it’s needed. The linked audio still doesn’t show up though.

Hey @SomeFedoraGuy, does the linked audio show up now?

Yep, and the site loaded pretty fast too! Thank you for fixing the issue.

1 Like