Sounds working in studio but not live

I recently created and uploaded a bunch of .ogg files for sound effects in my game.
They play in the web asset browser where I created then, they play correctly in studio when debugging the game, but they do not play in live.

Is there a common known cause for this? I am not seeing any console errors.

Link to one of the sounds thats not working:

If you have only recently uploaded the files they may still be processing on Roblox’s end.

If not, are you playing the sounds from a local or server script?

Also, in studio do you have ‘Accurate Play Solo’ enabled?


Fairly certain that you’ll always see or hear assets that you’ve created even if they get declined by the moderation team.

@robloxchickenrocket It could be because they’re not loading due to lag in your game (not sure how big your game is) but you could try preloading them.

1 Like

Okay, so I had accurate play solo disabled.

In accurate play solo, its identical to live in that only a couple of my sounds work. I guess I am waiting for the moderation team to finish moderating my sounds?

I hope they do!

All good now, thanks!

I am 90% sure this is not true. Declined/deleted assets will not load in and for good reason, whether for others or yourself. This includes copyrighted audio, which is subbed out for APM music (which is like, a list of 5-8 songs only, it’s not expansive or anything).

1 Like

GYou are right. My problem was entirely differences between accurate play solo and not.
Specifically I’d accidentally used a script on a client side only part to emit sound.

P.s are we ever going to get some of the restrictions on localscripts removed now that filtering enabled is everywhere? Adding effects to things client only would be so much more elegant if localscripts could run from anywhere in the tree.

1 Like

No, the restrictions will remain the same. LocalScripts will only ever be able to be ran from a replicated or client-only container to respect the environment, permission level and scope of that script. You shouldn’t really need to place them just anywhere in the tree either: you can already accomplish quite a bit with what power LocalScripts currently have.

where do i check if the accurate play solo setting is enabled or disabled?