Special Mesh Ingame Bug

So I tried making a race system. With you getting a random race and other stuff. but some races have other hair colors so we gotta change your roblox avatar hair color to the race hair color. It turned out great!!.. In studio sadly.

It looks good and all cause your normal hair color is now black instead of brown/white

but. Ingame it turns out like THIS?!

“BTW the TextureId was removed so it can be colored” So I checked the ingame with the dev console and it said the color was black. but ingame it isnt black??? I searched whole google and nothing came out even all forums to scripthelpers to devforum.

Im soo confused how this happend but I still found no choice execpt to leave this, it worked like 2 days ago still but now it just turns out white.

Can’t you just make the TextureId a completely white image.

then the mesh will be white and I cant customize it. it happend in other games too i saw it when I was playin’ some

Please try it before you say it is not possible, let me show you an example and explaination.
Step one change the Mesh.TextureId to a completely white image (completely filled in), it’ll look like so:
image image

Now change the VertexColor like so, if you wish to get the exact Color you want then follow the steps I put at the botom
image image

To get the VertexColor you want I suggest writing the following code in the Command Bar:

Color3.new(0, 0, 0)

Now move your mouse inside the brackets () and now press the colorful circle you see here:

Now the following screen will come up:

but I gotta change all code now and other games like Rogue lineage have the bug too what means roblox should start chaging it

I mean the only code you would need to edit is:

HairAccessoryMesh.TextureId = "rbxassetid://" .. "102461041"

Guess what… roblox actually fixed it