Specific badge giving 'Failed to upload icon' with all images

Detailed description of bug

Whenever I try and configure the image for this badge I repeatedly am getting the ‘Failed to upload icon’ banner regardless of the image (Even tested with an image which had been approved on another badge moments earlier.) This is only happening to this specific badge.

Where the bug happens (be specific)
On the configure badge menu of the roblox site.

When it started happening
Noticed this started occurring maybe 2-3 days ago, I tried again today and it still yielded the same error.

Screenshots and videos of the bug

Steps to reproduce the issue (be minimal, specific, consistent!)
Hard to give reproduction steps since it only occurred on this badge, Nothing was noticeable different between this badge and other badges, assuming its being reproduced on the linked badge, go onto edit menu and try and change icon then click save.

Side note that may help with repro

‘Won ever’ count has not changed in 3 days despite won yesterday count changing.


This is odd, is the problem still persisting? It could be that the moderation filter thinks that the image is inappropriate.

I’m not sure what the updated version of the badge looks like, so I don’t know what you’re attempting to change about it or what could be setting off the error.

1 Like

The problem is not with the image, we have tried over 10 images even ones which have been approved on other badges.

1 Like

This is really causing us development problems at the moment and would appreciate if this could be looked to, it may just be our badge since I have not heard any other developers reporting it.

Here is the console error:


I’m having the exact same problem, I even created a new badge and it’s still the same problem.

1 Like

I’m also having this problem with a couple of the badges for one of my games (but most of them still work when I try to change their icon). This is a problem for me because I made a bunch of placeholder badges with the same icon. Wondering if you ever came up with a solution to this problem because it doesn’t seem to be very common.


This is still an issue, can we get this looked into?


I’ll have to bump this thread, error still persists albeit using a different image twice atm


badge : Storm Squadron - Roblox
original badge image: https://tr.rbxcdn.com/adcc3c5b57c209b43c003de20c803356/420/420/Image/Png

It’s giving me the same issue…

1 Like