'Start server' caused my 3rd crash in 10 min [Incl. crashlogs]

A very lucky man :wink:

It’s studio not responding.
For several minutes.

1 Like
  • Is anything being choked in the Task Manager by either the server window or the first client window?

  • Does it happen on a blank baseplate?

  • Tried reinstalling or rebooting?

  • How would I see if studio is “chocked”?
  • Does not seem to be happening on Empty baseplate.
  • Reinstall roblox?
1 Like
  • Too vague on my part. Check studio’s memory, cpu, and disk usage for a sudden unreasonable spike that might imply a memory leak or infinite loop.

  • If not on a blank baseplate, can you give me a summary of what the server or client does on startup, specifically anything particularly taxing?

  • Studio. Yes. Although if it’s place specific, I doubt this will help.

  • Local file/Online Place/Team Create?

Doesnt use any more memory when trying to start the server.

But to be clear, its not the server crashing. It’s crashing the studio when trying to start a new server so it can’t be any code written anywhere by me.

1 Like

Can we have a place that could reproduce the crash?

I’ve tried to create repro but have been unsuccessfull. Which is why I’m wondering if it’s even sounds resonable that this could be the cause.

I require the module on both server and client but that should create 2 separate tables, wouldnt it?

1 Like

Maybe try disabling all server and client scripts to see if it has to do with instances in the place.

I don’t see how instances could be involved but I did disable all Scripts and LocalScripts and it still crash when trying to load a server.

1 Like

My studio has started freezing when I try to start a server while one is already running. It cleans up the running game instances, but then the main window freezes and doesn’t start a new server. I have to manually press the cleanup button before starting another server to avoid the freeze.

This doesn’t happen for me on a baseplate, but it does happen in my larger place file - I also experienced it on the Volcanic Island template place. Might be an issue in files where there’s a lot to load?

I have also been having a lot of trouble with this.

My rbxl file is 15.7MB, how big are your files?

1 Like

Is there any more information I need to provide?
This happens rather frequently making it difficult to debug my game.

This is happening to me too. My place is 5 mb, and I’d be happy to message someone a repro file. Running Windows 10 as well.

For me it is seemingly random, but happens really frequently. It also occurs when I start a 0 player server too.

Mine is 3.25 MB, and it’s started happening to me randomly as well, not just when having to clean up a running server. It seems to very frequently happen the first time I start Studio for the day, then the crash rate is reduced for some time afterwards. This all started happening after last week’s update.

Could we get some feedback from staff on this issue?
Having to restart studio every second time I start a server is a close to critical issue.

Another hint: Seems to be more frequent if you have an item selected or semi-selected (like this image) when pressing play.

They actively read the bugs categories, give it a bit and I’m sure we’ll see a staff response.

No feedback because there’s no actionable information in this thread. Next time this happens, go to:

%localappdata%\Roblox\logs

Sort this folder and the archive folder by Date Modified, and pack the files in this folder and the archive folder that were last modified around the time of the crash into a zip, upload that to dropbox/google drive, and link it here.

Oh, didn’t even know that existed!

Well here are the last 3 crashlogs:
https://drive.google.com/file/d/1q1s7eEHigLrTRkz-GOfEv1eFMnZVZ4xz/view?usp=sharing

I am uncertain if log_8BDAF_1 was a full studio crash or not. But the other 2 files are reports of crashes that occured simply by opening a studiofile and pressing ‘start server’.

For clarity: Crashes means ‘Program not responding’ and never reponds again; even if you wait 5 minutes.

2 Likes

I’ve been having this exact same issue unfortunately. Here are my recent logs, with log_C9BF7_1 being the most recent one to immediately follow a crash.