StarterCharacterScripts don't work

So. Recently I have been making a 2D game. The whole game was GUI based, there was no necessary actions needed to be taken outside the GUI. So I add some kill scripts, however after using some scripts from the forums to disable reseting, disable movement and remove the topbar. Only 1/3 of the scripts worked. What’s going on?

The only script that worked was the “Hide Topbar” script which while successful. Ehhh, apparently roblox made it so you couldn’t hide all of it. No biggie. It did a semi-good job of hiding everything else but the esc menu. Still, it worked.

The other’s… not budgin’. They don’t wanna work.
The other 2 scripts that don’t work are “Kill Movement” and “Kill Reset Button” scripts.
Now… Weird thing is… These things work only on studio. Not on the player.
Like what???


Kill Reset Button script

local StarterGui = game:GetService("StarterGui")

Kill Movement script

local controls = require(game:GetService("Players").LocalPlayer.PlayerScripts.PlayerModule):GetControls()

Both of these scripts were taken from the forums.


Studio reset script

Studio movement (Not really clear but… I can’t move.)

Roblox Player Reset

Roblox Player Movement

All scripts are local scripts and in the StarterCharacterScripts folder. I changed it to StarterScripts folder but same result.

1 Like

Did you published your studio? If yes, re-publish and try again. If no, publish it and try again.

I did re-publish it many many times over. It doesn’t fix the issue.

Can you add prints into your scripts and tell me if they are printing?

Do you have any errors in the output that you can show me?

Only error is with the Kill Reset script

Try putting your Kill Reset Script inside of StarterGui. I do this, and it seems to work for me.

I added prints to the scripts. The movement script fully executed without errors. But it doesn’t work.

The kill reset script broke midway.

print("Begun Kill Reset")
local StarterGui = game:GetService("StarterGui")
StarterGui:SetCore("ResetButtonCallback",false) - Error on line 3
print("Disabled Reset Button")

This problem has already been solved here by putting this instead :

local coreCall do
	local MAX_RETRIES = 8

	local StarterGui = game:GetService('StarterGui')
	local RunService = game:GetService('RunService')

	function coreCall(method, ...)
		local result = {}
		for retries = 1, MAX_RETRIES do
			result = {pcall(StarterGui[method], StarterGui, ...)}
			if result[1] then
		return unpack(result)

coreCall('SetCore', 'ResetButtonCallback', false)

Do you have it in the wrong place? (It seems like you put it in the wrong place due to the ... has not been registered by the CoreScripts)

Same thing.
Doesn’t work. I used that exact script but removed the unnecessary bulk.
My version of that script is the “slim” version of it.

Here’s proof that that script doesn’t work:

Could you please show the output?

I don’t know that’s my question too!

Try putting it into StarterGui or StarterPlayerScripts

Like @P1X3L_K1NG said, try putting it into StarterGui or StarterPlayerScripts. Personally, I always put this in a local script in StarterGui.

Well… your idea sort of worked. Movement is now frozen however the reset button is enabled in studio and the roblox player

Are you calling :SetCore from that local script in Startergui?

Pretty much.
I have done just that.

You should read the topic I sent you above earlier.

This doesn’t work. Apparently it’s outdated perhaps?
Roblox has been changing a lot recently.