StarterGui:SetCore(“ChatActive”) does not behave as intended with Enum.ChatVersion.TextChatService

Reproduction Steps

  1. Enable the New Text Chat Service beta feature

  2. Attempt to run StarterGui:SetCore(“ChatActive”, true) or StarterGui:SetCore(“ChatActive”, false) on the client

Expected Behavior

  • The TopBar chat button will change its visuals depending on whether true or false is passed within StarterGui:SetCore(“ChatActive”)

  • The chat GUI will show/hide itself depending on whether true or false is passed within StarterGui:SetCore(“ChatActive”)

Actual Behavior

  • The TopBar chat button successfully changes its visual appearance depending on whether true or false was passed within StarterGui:SetCore(“ChatActive”)

  • However, the chat GUI remains unchanged, requiring the user to click the TopBar button if they want to toggle the chat GUI


  • Currently cannot find a workaround, needing to use LegacyChatService to meet the use case where StarterGui:SetCore(“ChatActive”) is required.

Issue Area: Engine
Issue Type: Other
Impact: Moderate
Frequency: Constantly


This has been a consistent thorn in our side, you wouldn’t (or maybe you would) expect a new iteration of a feature to actually hold such significant a regression as this. It’s imperative devs are able to disable/hide chat, just as players are; forcing developers to use crude workarounds or wait for a fix isn’t sustainable…


Able to reproduce.
The same issue also occurs with ChatBarDisabled, ChatWindowPosition, TopbarEnabled, and ChatMakeSystemMessage. This is a real issue as many games rely on TopbarEnabled and these other SetCore methods.

So, anything except for SetCoreGuiEnabled doesn’t work with the new TextChatService.

Is there a reason why you can’t use TextChatService.ChatWindowConfiguration/ChatTextBoxConfiguration.Enabled?

This was one of the first things we tried, but it doesn’t work in the way we want. If we disable the chat elements via this then the user can’t re-open them by toggling the button in the topbar. We simply want to have the chat UI minimised (but still accessible) by default when the game begins.

Ah got it we’ll look into this!


This should be resolved now, please confirm!


Sorry for the belated response. Can confirm this now works - thank you!