Stop Moving Links into Markdown By Default

As a Roblox developer, it is currently too hard to paste links properly

This is my largest annoyance with the site that cant be fixed locally.
This is what happens when you paste in some links.

I’m extremely sick of this happening, it’s incredibly annoying to link topics, because it (in a way) autocomplete

If Roblox is able to address this issue, it would improve my experience using the forum because I would be able to quickly paste forum links without the [link stupidly completing!!]()


I believe this would be better as an option instead of being forced, since having a link auto format in paragraphs of text is helpful.


This isn’t autocompleting. I’ve noticed with the devforum specifically across many devices and many browsers that the links won’t copy. I have no damn clue how this happens as this is impossible and I nor anyone else can’t replicate it with another website but it’s happening. Only way to do it is to just copy from the share button.


At least manual switch in user option.

1 Like

I have never experienced this, there is something else at play than just the forum itself.


It’s possible that it’s a browser problem. Which one do you use? I noticed that @DarkPixlz and I both use Microsoft Edge, so that could be a possibility.

1 Like

im using edge on windows 11, is this possible a bug? I’m incredibly sick of this happening when I try and link topics

1 Like

Sorry I’m n my phone and I forgot to reply to you, read the above comment

Sorry, I’m not the sharpest tool in the shed. You’re talking about the whole [topic name - subcategory / category - devforum / roblox] (link) thing? If so, I’m confused as to what’s so problematic about this?

1 Like

Yeah, it automatically turns into ‘[Topic name / Category / Roblox Devforum(link)’ instead of directly linking to the topic, it also does this to other websites, I showcased Roblox sites

Paste without formatting (CTRL + SHIFT + V) can paste without the markdown.


What is the behavior you are expecting/would like to happen?

The links are being auto-formatted into markdown for you, by fetching the page title to be used as the link text.

You can always modify them though! Markdown links follow the [title]( format. All you have to do is change the title text to whatever you wish, the title can even the link itself.

1 Like

I don’t want it to be out into Markdown By Default, I want it to display the dawn link alone.

I noticed that this happens especially in Microsoft Edge. On edge://settings, there is an option to autoformat links and you can avoid it by typing Ctrl+Shift+V intead of just Ctrl+V