Stuck on Joining Server (Not a connection problem)

Hello there,

I’ve been having problems with my new game lately. The problem is that I get stuck on the “Joining Server” screen for a long time.
I tried disabling all of my scripts, same result, I get stuck for at least 2-3 minutes and the game isn’t that heavy.
But here’s the twist, I don’t experience any problems on Studio when I start playing on it.

I also watched the F9 menu on the Joining Server, nothing loads in the server but the client gets infinite yielding warnings:

I looked for solutions on the forums, but I found nothing.
I also don’t have any “viruses” in my models as I built everything by hand.

I can join other games easily.


Can you check the memory tab? See if the game consumes a lot of memory when it takes a while to load.

iirc, having a lot of unions and/or meshes in your game greatly increases load time.

1 Like

I can’t even get the server stats.

1 Like

did you modify roblox’s core gui by any chance… it looks to me you tried to make a new player list and modified the script, but if you didn’t then you might want to ask roblox or a higher up scripter.

I didn’t modify anything in the Core.
I only modified the Chat Size manually on the Chat service.

its seems that it cant find the SetPlayerBlockList, NewPlayerGroupDetails, GetServerVersion, and CanChatWith, if you know were those are stored you could try to fix it yourself since you have the Programmer Tag, but i wouldn’t really recommend that since you might break something just a suggestion. I Would try to get in contact with roblox or a big programmer if i had this problem.

Well, we can’t modify core scripts I think.
The programmer tag doesn’t mean anything and I need help fixing it, that’s why I submitted this post.
Don’t leave a comment if you have no idea.

I was going to make a thread about this but I searched anyways I got this issue too I tried joining my game this morning and it would not let me in it would load for 5 seconds then my roblox game would crash (I’m using mac not sure how windows handles it) after shutting down the server and joining it loaded slowly which was very weird because it would usually load in pretty quick and I have fast internet so I checked the console and I saw I had the same warnings as OP showed. I’m thinking this is on ROBLOX’s side as other players were complaining to me that they could not joined and while this was going on I joined

And no, I have not modified anything besides what I can see in studio.

Nevermind, just happened again on my regular internet this is a roblox server issue.


How big is the map? Sometimes creating maps that span great lengths could cause this, happened to me before.

1 Like

The map is quite small with many meshes that are quite lightweight.
I don’t think the map is the problem here.

If you don’t mind linking the place I could see if I’m able to join or not. My only other advice is to create a new baseplate and then transfer everything over to the new baseplate and seeing if you can join the new place.

I’ve ran into this issue a couple of times, here is what I did to fix it, and was usually always one of the problems.

While Loops
First off, this could be an error because of a loop is going to fast that is infinite (or goes on for too long) and lags Roblox, so Roblox throttles.

It’s a good practice to do the following when making while loops, here’s an example:

while wait() do 

If you’re struggling to find the loop, you can most likely look in the logs, if they don’t show I recommend searching using “FindResults” in the “View” tab of studio.
Search for the following in ALL scripts: “while”

This error could just be Roblox having some issues, in that case, I’d recommend taking a break for a bit and it may resolve itself, if it’s constant, I recommend contacting Roblox about it.

Invalid Texture,Image,Sound Ids

This has happened to me on multiple occasions. Invalid IDs can sometimes delay things, I recommend reducing those kinds of errors.

Big Scripts
Big scripts such as Adonis Admin, and maybe F3X can potentially cause this error when you’re game is quite large. I recommend either making your game smaller or removing these scripts and trying other ones.

Accidently Modifying Core Scripts

As some people stated above, accidentally modifying core scripts or even worse, putting in a script that modifies them can cause this kind of error.

If you find yourself wanting to edit/replace any of these scripts I highly recommend you Disabled them, and then create one in the place of them to avoid any conflicts.

Connectivity Problems (Your Connection)

If you’re on studio especially, this type of error can happen by your internet going out at the same time you play the game and load the player, character, and GUIS.


Thank you for this complete answer, I fixed some things with the game and the loading is now a bit faster!

Again, thank you! :slight_smile: