Studio being permanently muted

The problem
When I play a sound in normal studio mode (not starting any servers nor playing locally) I get no sound at all. It’s been like this for a while (3 months+) but it’s really starting to become annoying.

Things I’ve tried

  • I checked volume mixer
    Studio is on full volume but registers no output when I press play on Sound objects.
  • I’ve clicked and unclicked the Mute button in studio
  • Changed ‘Server Audio Behavior’ to Enabled and ‘Online Game’

None of these work.

Sounds works when I start up local servers, altho it’s always set to 0 on all clients.
No idea what else to try, this must be a bug right?

4 Likes

Is your actual in game volume more than 0? Audio in Studio is influenced by your in game volume.

2 Likes

My ingame volume was on 0. I changed it to 5, exit and rejoined and it was at 5.
Then I restarted studio but the sounds are still muted.

Still wierd how ingame volume would affect my studio volume?
For test-server clients I’d expect such behavior but for pure studio coding there’s no need of correlation imo.

Just to clarify, I get no sound when I press this button:
image

1 Like

OHHH!!
I had to join by pressing this
image
Then go in settings, increase volume then press leave game.

Now I got volume back! Awesome!
Thanks @Kampfkarren :smiley:

6 Likes

This is a known bug. You can support this thread here to have it use your desktop audio:

2 Likes

It’s not necessarily a bug, we just need to make audio in Studio independent. In the meantime, the above is the solution.

5 Likes

I just got this issue, I figured out that my client volume is 0. But when I increased it, I still couldn’t hear the preview sound. So the client volume doesn’t affect the studio. I turned off an option in studio settings called “Only Play Audio from Window in Focus”, after that, I restarted the studio and the preview sound worked again.

3 Likes