Studio Bug?: Problem with ROBLOX Studio plugins

Asking for help for a friend whom with I’m working on a game, he’s having major issues with ROBLOX studio plugin installation and is unable to find any similar problems and, therefore, a solution. He personally feels this is a bug with ROBLOX studio and wrote this up for you guys:

I am unable to use any ROBLOX Studio plugins at all – they fail to install. The problem is not place-dependent and has persisted after reinstalls of ROBLOX Studio.

The error itself, as copied from the Output window:
18:17:15.060 - Unable to load metadata for installed plugins. Installed plugins will not be loaded.

When I click ‘Manage Plugins’, I am presented only with the word ‘Plugins’ on the left and the blue ‘Find Plugins’ button. When I install a plugin (as noted, any plugin), the following appears in the Output window:

18:25:26.352 - Plugin metadata file is corrupted. Version information for your plugins may have been lost.
18:25:26.353 - Finished installing plugin. Open a new window to start using it.

My plugins folder (C:\Matthew\AppData\Local\Roblox\Plugins) remains totally empty. The plugin does not appear in Studio, following either a new window being opened or a total Studio/system restart.

Technical info:

CPU: i7-4770k at 3.5 GHz
Motherboard: ASUS Z87 PRO (firmware is latest version)
Memory: 16 GB (2x8 GB)
GPU: GTX 780 Ti
PSU: Corsair GS700 700w
Drives: 500 GB & 256 GB Samsung SSDs

Windows 10 64-bit - the OS I am running Studio with - is installed on the 500 GB SSD.
Fedora 24 64-bit is installed on the 256 GB SSD.

ROBLOX Studio Version 0. 252. 0. 79695

3 Likes

This should probably go in the section of studio bugs. If you put it there a staff member will respond faster since they patrol those sections of the forum more.

Alright, just wasn’t sure if it was a bug or simply a problem on his behalf.

I and my friend were editing a game and we couldn’t install plugins that we were gonna use. Can confirm that we have experienced this bug or one that is similar to it.

2 Likes

I just thought I’d post an update on the fact that he fixed it himself, although he wasn’t sure what fixed it, as he reinstalled ROBLOX completely twice (deleted all content related on PC), restarted computer, and tried switching his operating system over and back.

1 Like

You can manually install a plugin by editing the PluginThingy.json file.
Just copypasta an entry and change the key to the assetid of the plugin you want.
(I also set AssetVersionId to 0, not sure if you have to do that, but eh)
Then just go to the (or refresh your) Manage Plugins page and click “Update”.
(the plugin will suddenly be in the list, by updating it, you properly install it)

I can’t install plugins, but I think that’s related to me replacing QtWebKit4.dll:
The “Install” button doesn’t do anything, no output or stuff, hence I blame my fix for lag.

1 Like

You could also try deinstalling Studio and then going to %LocalAppData% and deleting the ROBLOX folder there (after backing it up in another place), then reinstall Studio.

1 Like

I am also having an issue where I can’t install any plugins.

2 Likes

Thanks for the reports, we’re investigating this issue.

6 Likes