Studio camera mouse input drifting

Reproduction Steps

Enable the new icon / DPI aware studio feature

  1. Use a 4k monitor
  2. Open up empty baseplate file
  3. Start a play test and go into first person view
  4. Move camera left and right

Additionally (may or may not be related)
My windows scaling is set to 200% as shown below
Screenshot_5

Monitor specs
Name: ROG XG27UQR
Resolution: 3840 x 2160
Refresh rate: 144 Hz

Expected Behavior

The camera should move in the direction of the mouse without drifting

Actual Behavior

When moving the camera only left and right, the camera drifts in a downwards direction

When moving the camera only up and down, the camera drifts in a constant left or right direction



Workaround

Currently the only workaround is to disable the DPI aware feature because it doesn’t occur with the old studio DPI settings.

Issue Area: Studio
Issue Type: Other
Impact: High
Frequency: Constantly
Date First Experienced: 2022-11-17 11:11:00 (-08:00)

11 Likes

Same thing happens to me only when I have the DPI aware feature on. Alongside this issue rotating the camera left slowly becomes impossible for me as the camera drifts and snaps back towards the right immediately.

2 Likes

I am also having this problem with a 3440 x 1440 screen. I have set the Player.CameraMode option to LockFirstPerson and the problem is solved. However it is still annoying when you don’t wan’t to do a First Person game.

I have the same thing, only not during the test, but in the studio itself.
I accidentally found that the problem disappears if you go into full screen mode.


And when you turn off the beta menu, the old one breaks…

roblox urgently need to fix everything

1 Like

Can add this is happening to me when in just the general studio editing mode. This is me just moving the camera up & down, as can be seen with my mouse movements, yet the screen is moving left & right.

1 Like

Thanks for the report! We’ll investigate!

4 Likes

This also happened to me. I tried re-installing studio, which did not help. The only fix I found was to unachor the edit mode tab, which is a pain when re-sizing other tabs

Happened to me as well
!!!