Studio closes immediately after the stop button is pressed

Reproduction Steps
Since a studio update an hour ago, my projects started crashing when leaving testing mode:


The crash also happens with a project that has been running fine for the past 2 months untouched.

Windows 10, i5-11600KF @ 3.90 GHz, 32 GB RAM

Using beta features:

Expected Behavior
More often than not I would very much likely expect studio not to crash

Actual Behavior
Studio crashes every time I press stop


Issue Area: Studio
Issue Type: Crashing
Impact: Critical
Frequency: Constantly
Date First Experienced: 2021-08-25 10:08:00 (+03:00)


I imagine you’ve already done a clean Studio install a few times, right?
But have you tried it on another Windows (another computer or VM)?

Crashes for friend too - his projects are unrelated to mine.

For some weird reason, from my testing so far, empty projects dont seem to crash. Some random places with code may or may not crash.

1 Like

Just tried this on entirely empty project with just a Baseplate, and I had the same problem. I tried reinstalling and had the issue happen again.

I got the 492 version some minutes ago… have you test it?

I crash as well by Entering and Exiting Play Mode, but the crashing seems random on my project, sometimes it takes multiple attempts and sometimes it crashes on the first attempt.

Version: 0.492.0.4920395 (64bit)

Windows 10, i5-8300H, Nvidia Geforce GTX 1050Ti 4 GB, 8 GB RAM

Beta Features Enabled:
Adaptive timestepping
Pivot Editor
Script Version History for Non TeamCreate games
Terrain Quality of Life Changes

Edit: Also reproduced on New Baseplate project by constantly Entering and Exiting Play Mode

1 Like

Same issue for me, it happens about every 3rd or 4th time.
I installed Studio on a fresh VM and recreated the behavior, I could not locate a clear cause of the error, I just hope that the problem will be fixed with the next update.

Im also having this issue, I sent a message to bug-support but Im glad its not just me.

I can’t seem to reproduce on MacBook Air M1, so it seems like a Windows issue only.

This might be because Roblox’s site is down. Website is not reachable on Windows. I tried opening studio but meshes won’t load for me. There’s no official saying by Roblox that it’s down.

Studio seems stable now after reinstall


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.