Studio crashes after opening specific place file

Whenever I try to open a specific place in studio (team-create or local), it crashes soon after.

Downloading the place file with BTRoblox returns a file with ascii text: null and 4 bytes.
Upon inspecting, that was issue with how the extension handles corrupt files. Downloading the place file via
assetdelivery gives me actual file; but it’s still corrupted.

Downloading previous versions yields similar results.

The issue is not related just to me; as other developers can’t open that place either; even though it’s currently published without problem.

This is massively obstructing our development; as we can’t update the place and we relied on Roblox version history for version control.

5 Likes

If changing the version back a few versions doesn’t fix it, I’d say that fixing it is all in Roblox’s hands. - If rolling back fixes it, it’s just a random Roblox update bug, but if it doesn’t then that’s definitely something that should be looked into.

Were any significant changes done before this happened? Or did this just suddenly appear out of nowhere?

Also, have you tried reading your crash logs? If memory serves correctly it’s at least human readable in some parts, enough to at least give you a vague idea of what’s going wrong.

I’d assume that the game still plays fine for the client, it’s just something about it that studio doesn’t like. (on mobile, can’t test it at the time of this reply)

1 Like

There were no significant changes done before this happened.
Logs show nothing significant to me.
The game works on client; studio is the problematic one.

2 Likes

Hello! Can you please upload the assetdelivery place file for us to look at? Please feel free to send via DM if you do not want to post publicly. Thanks!

1 Like

Thanks for the report! We’ve filed a ticket to our internal database and we’ll follow up when we have an update for you.

3 Likes

something very similar to this is happening to me. I have not experienced this until recently. This issue has happened to me twice for different place files. The first file somehow deleted itself as it no longer shows in the roblox studio menu however is still visible inside the “file explorer” of my pc

2 Likes

Hi @Legoracer. By any chance do you have Beta Features → Cage Mesh Deformer turned on in Studio? If so, can you try again with it turned off and let me know if the crash goes away? Thanks for your patience!

3 Likes

It seems that Cage Mesh Deformer was responsible for the crash after all.
We never tried disabling Beta Features due to the problem being isolated to only one place file.

Thank you for the help.

2 Likes

We have a bug fix merged that should fix this, it should get released in a couple of weeks at which point you can start testing Cage Mesh Deformer again if you like. Thanks for your patience!

3 Likes

Once this fix is released, the crash will go away, but I wanted to show you why this place was triggering the crash in the first place. There is a skinned mesh Braum_Santa that has many hundreds of environment Parts grouped into it’s model:
bad_santa
Because Parts can also be used as skinning influences, they overwhelmed the skeleton code, causing the crash. I thought you might like to know because you probably didn’t intend to have it set up that way and it is not very efficient even when it doesn’t crash. There are also a lot of environment lights, meshes and other things in his Model that you probably didn’t intend to put there.

2 Likes

Thank you for clarifying what was happening.
That was definitely not meant to be grouped like that, but I guess some co-workers did it by accident.