Studio crashes every time I try to publish a model to the toolbox

My studio seems to crash every time I attempt to publish a model to the toolbox, it loads to 95% roughly and then the whole app just closes all of a sudden.

Things I have tried to troubleshoot:

  • I have tried to publish on my laptop and desktop pc (both have the problem)
  • I have reinstalled Roblox studio and the problem persists

Does anyone think they know what this might be and how I can fix it?


Hi there, is this a particular model? Or have you tried multiple?

Could you provide a screenshot of the exact model you are trying to publish? Are there scripts for that model? Is this reproducible if you simply try to publish a “Part” as a model?

it only happens when I select a group of meshes and scrips as well as models. It shouldn’t be enough to make my pc crash as its only around ~10 items selected for publishing to the toolbox.

I’ve tried it with just a single model from the selected ones and it seems to work fine, same with the one containing scripts. I’m still not quite sure what may be causing this.

here’s a quick screen shot of what I’m trying to publish:

is there any other way to move models with scripts from one experience to another without encountering this problem?

Copy the models using the keyboard shortcut.

Additionally copy the models to another blank baseplate and send them in a bug report for further investigation.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.