Studio Crashes immediately after 100% of loading whenever a place or file is opened

Doesn’t seem to do anything. Would you like the new log and dmp files?

1 Like

Please DM me the new dump & log file after the Intel one has been disabled.

Today I am taking a sick day and may not be responsive…

I’ve tried opening Studio again and miraculously works. But when I try to open it up for a second time, the viewport is blank, white. However I could add parts, change properties, etc.
When I try to open a place file via Studio with the white blank viewport, the studio crashes and followed by this error message.


Opening Studio fresh for the third time, it crashes too.

1 Like

Can confirm that this is replicating with me as well. Unable to open anything in Studio
image

2 Likes

Is roblox looking into the issue or is this just known that it’s happening and some developers just don’t have access to roblox studio?

3 Likes

After trying to use Studio again, my described problem was gone and I was able to open any places or files without having to disable my Intel card. Not too sure if this is a one off problem, will edit later when I reboot my machine. Is there anything that could be useful that I could probably contribute? E.g log files. I’d gladly help in whatever ways I can.

It is likely that your driver was updated & AMD fixed the crash.

We now have a detailed guide on what you should include for various kinds of bug reports:


As long as you include everything there, that should be plenty! Though, with bugs like this, there’s not much we can do aside from wait for AMD/NVidia/Intel to fix their driver.

2 Likes

After updating my drivers, my studio started crashing again and again. I have the latest drivers on my PC, with GTX 1060 3GB, Core i5 CPU 3.5 gHz, 16 GB DDR4. Is there a way to revert drivers back versions?

You could try asking for help on the AMD or NVidia forums, whichever is appropriate for the GPU you have:

https://www.nvidia.com/en-us/geforce/forums/discover/
https://community.amd.com/community/support-forums

1 Like

Thank you! I was able to fix my problem after contacting and getting assistance, like you requested. I went on ASUS website and found my graphics card, and I downloaded and installed the content creator driver from 2019, and everything worked perfectly and no longer was crashing!

1 Like

Okay, so my Roblox Studio AND Roblox game is continuing to crash, even after reinstalling drivers to different versions MULTIPLE times. It’s getting irritating for me, and I do not know what is going on.


log_D3BB9_1.txt (12.6 KB)
DxDiag.txt (120.6 KB)

I was having this exact issue, and I also have a GeForce graphics card (though not the GTX 1060 that you have, mine is just a GTX 850M). I was crashing about 80% of the time, which was extremely annoying so I reverted to an old driver and the crashing immediately jumped to 100% of the time. I kept trying drivers until I found a game-ready driver from 2017 (382.05) that seems to not have a strong hatred towards Roblox.

I’m not super happy with having to use an old driver just for compatibility with Roblox but it works and it’s my only option at the moment.

Here’s the desktop version of the driver that I’m using. GTX 1060 is supported so you can give it a shot.

1 Like

I figured out the primary problem to my freezing up. The problem was not the graphics card, but the additional software I downloaded for it. I downloaded a bunch of MSI softwares, such as one that monitors the graphics card, the BIOS, and one that checks the drivers are up to date, and after searching for 1-2 days I figured out that the problem was obvious. I uninstalled all MSI softwares (excluding the drivers, ofc), and nothing freezes anymore. :slight_smile:

2 Likes

I’ve been having this issue lately too. We have extremely similar specs. Every now and then Studio stops responding and the screen flashes, then responds again but the viewport has gone white. The Roblox Player does the same thing but I end up having to kill the process. The only way to avoid this is using an extremely low graphics setting (2-5).

I just did a full uninstall and reinstall of both Radeon Software and the actual driver for the chip but this hasn’t fixed it. I will try uninstalling any software except drivers as @mrfrogg1 suggested and let you all know the results.

UPDATE: Uninstalling Radeon Software didn’t help. This seems to be an issue with Roblox and driver interaction.

Full specs:
CPU: Intel Core i7-8550U
GPU: AMD Radeon R7 M460
RAM: 16GB DDR4, 2400MHz
SSD and HDD: 128GB NVMe and 1TB respectively
OS: Windows 10 Pro 1903 build 18362.720

2 Likes

Update as well: I’ve been having this issue even after changing drivers, but less frequently in player but more frequently in studio.
My beta features that are enabled are:

  1. ConvertTool Beta
  2. The rest are all disabled

Whenever I minimize ROBLOX Studio, I always come back to opening it frozen. As an addition, there are times where my game freezes up and stops working while coding (Which leads to me having to re-write the code again, but later learned to turned on team create so things autosave which is very nice).

I want to add additional information: OS is Windows 10 Home Edition
log_E56CA_1.txt (62.4 KB) log_57860_1.txt (115.7 KB) log_AB20B_1.txt (21.6 KB)

2 Likes

Alright, I believe I have finally found a solution I am confident works.
If you have a GTX graphics card, I believe this may be a valid solution for you. If you download the NVIDIA GeForce Experience application, you should be able to install the latest version of drivers that is from the manufacturer. As an addition, you can install the “Studio Driver” which is built to handle various situations that may freeze randomly. Performance on this Studio Driver is identical but teeny tiny slightly less performance (like a 0.05% difference here, almost negligable), and so far I have not seen a crash. Also, the Studio Driver version is NEWER than the Game Ready Driver, so you may see a fix if you are having issues and switch between Game Ready and Studio.


If you are using AMD’s internal graphics, I’m assuming they may have something similar as well.
Note: This is just a guess, but maybe try checking here
https://www.amd.com/en/technologies/radeon-pro-software
" AMD Radeon Pro Software for Enterprise 18.Q2 was the “most stable driver in the industry,” according to QA Consultants.1"

2 Likes

Another solution may be to downgrade your BIOS. I was browsing the Dell forums and many people were suggesting doing so, and that seems to have fixed my issue.

1 Like

Now that I checked, I believe my BIOS was heavily out of date. (The BIOS was 4 years behind the latest version). I have updated and hopefully that may make a difference :slight_smile:

I gave it a couple of days and the problem started emerging again.
I am getting pissed off because my studio freezes while I am scripting, causing me to do 2x the effort and time to actually get things accomplished, and I’m getting quite mad. I have a GTX 1060 3GB running a 2560x1440 at 144Hz, which the graphics card holds a steady 37 degrees celcius, and yet Roblox Studio and Roblox itself keeps crashing with D3D issues. And because of this issue the release of my game is being pushed back further and further. I’m sick and tired of this nonsense.log_F1B35_1.txt (9.6 KB) log_F1A70_1.txt (9.3 KB) log_453D5_1.txt (8.4 KB)
IRRITATING

1 Like

I am sorry for posting once again. I believe I have found the problem. My monitor is a 144Hz monitor and Windows 10 decided to trick itself in saying that it is a 144Hz, but in the actual driver settings it was set to 60Hz. This caused the D3D to time out because the refresh rate was anticipating 144Hz, but instead got 60Hz, which inevitably resulted in Roblox studio to crash alongside Roblox as well. I have noticed the hanging to exist in both Minecraft and even on Chrome. So this isn’t necessarily a Studio bug (although I seriously thought it was). I’ve been stuck with this problem for months, and I’m glad it’s finally resolved.

1 Like