Studio Crashes When Opening Saved Place

If this is posted in the wrong place, please let me know so I can get it to the right place.

When I enabled the Roblox Studio Beta Feature: “Enable New Lua Script Analysis” my Studio crashed every time I tried to open a saved place. I also have the other Beta Features enabled except for “Script Editor Folds Behavior Beta”.

How often does the bug happen (Everytime/sometimes/rarely)?
This Happened every time I opened a saved place, opening a new place was fine.

Where does the bug happen (www, gametest, etc) www / Roblox Studio

Would a screenshot or video help describe it to someone?

Beta Features

image

When did the bug start happening?
When I enabled the Beta Feature.

This is very likely this issue:

You should do more troubleshooting before reporting a bug like this. There is absolutely no useful information in this thread that can help engineers find the problem if it happens to be different from the one above. These guidelines are undergoing revisions, it might be helpful to give them a read.

I could open any place with it that was saved and it would just stall when trying to open the place. One with a script just with a simple “Hello world!” print would stall it.

Opening a brand new place was fine however.

I’m not sure what other information I can give, and I tried looking for other things about studio stalling and only found older reports from 2018, and none of them had to do with this one Beta Feature, that when disabled, allowed me to open saved places again.

It wouldn’t let me open ones on Roblox or saved locally.

Can you try disabling all of your plugins? Not sure if they could at all interact with the new script analysis features but it’s worth a try. If this helps, try enabling them one at a time until you find the one causing the issue.

Left my plugins enabled, re-enabled the Beta Feature and opened a place I just saved with a single server script with a print in it and it loaded fine (but it didn’t before. Weird). Loaded an old place of mine from 2011, worked fine (Also didn’t work before).
Loaded one with AeroGameFramework, and it froze studio.

@BIoximus I uninstalled and reinstalled studio multiple times to no avail.

TL;DR; It’s fixed now, turns out it was just games with AGF, however when searching for the 2 or 3 hours I did before making this post, I didn’t find the one Pez linked, and only found ones from 2018.
Beta Feature “Enable New Lua Script Analysis” and AeroGameFramework, don’t get along too well.

1 Like