Studio Crashes When Opening The Object Browser and What's New Menus While Editing Place

Studio just updated back to the ‘new and improved’ inaccessible icons at the time of this post.
If I try inserting something, studio crashes (meticulous quality assurance)

This is a fresh installation on a fresh computer of both Client and Studio.
Context:
I had to destroy everything because of the Update 280 error I got attempting to disable the equally unwarranted InApp, said error still persists for just this Roblox account, not even specific to browser.

3 Likes

Platform & Spec:

Manufacturer/ Model:

MSI GS76 Stealth 11UG-232

Specs:

OS: Windows 10 Home (fresh installation, fresh installed drivers from OEM)
CPU: Core i9-11900H @ 2.5 - 4.9GHz
Chipset: HM570
GPU: NVIDIA® GeForce RTX™ 3070 Laptop GPU (fresh installed drivers)
Video Memory: 8G GDDR6
Memory: 32GB (16G*2) DDR4 3200MHz
HDD Capacity: 1TB NVMe SSD (Interface: NVMe )

Full Source: MSI Website (see MSI GS76 Stealth 11UG-232)


Multiple Monitors (Laptop, HDMI cable to Samsung C24F390


This is only with the new icons. They went away but just got brought back

1 Like

I just tried this. It worked. I can now see the Ctrl + I menu without crash.

Thumbnails in startpage do appear black. File new > open a place, things did not freeze.

1 Like

I got the “patch” today on my main, and it now crashes again. However, I can thankfully use the Roblox player now. I’d rather wait until a patch is done so I can still play Roblox.

I have tried everything on the new version that normally would crash and there is absolutely no difference. Something definitely is incompatible with this version as the object menu does open but crashes when it tries to load.

Solutions I tried:

  1. I’ve made sure that I am on the most recent version of Windows 11.
  2. I updated my graphics card drivers.
  3. I did a clean install Roblox Studio.
  4. I’ve replaced .dll files to ensure that they were the most recent versions or to ensure that they weren’t corrupted.
  5. I have made sure to have all of my plugins disabled when testing. None of them were causing the crash.

Nothing seems to be working, no matter what I tried. Roblox Studio would only crash on the version with the new icons, as I tested when I was brought back to a stable version (which, I don’t want to do again since I couldn’t use the Roblox player).

Things I noted during the crashes:

  1. All crashes don’t have the “An unexpected error occurred and Roblox needs to quit. We're sorry!” pop-up.
  2. Roblox Studio doesn’t have any issues with CPU, GPU, or Memory according to task manager.
  3. A white box shows up when opening the InsertObject menu from the context menu or the + button.
  4. The ribbon menu object browser opens up, but can’t load at all and immediately crashes.
  5. The What’s New menu doesn’t even have a chance to load at all, but works perfectly fine in the start menu.
  6. All these issues have started happening with the new icons update. It has never had any issues in the past.

I have been testing if any other methods are a problem and ensuring that everything can be worked through.

3 Likes

My studio got updated back to the version where I keep crashing trying to insert an object, just like @sinistersecret02 , @MrGreystone and @hunterk1241 have stated above. The patch seems to have done nothing but revert me from the beta branch to the broken version.

3 Likes

Studio still isn’t working. It worked the first few times I opened it, then suddenly froze. Once I shut it down and opened it again, Roblox studio wouldn’t respond. The games never loaded - just a white screen.

Dual monitor, same specs as my reply above.

What studio looks like when I try to open it

If I could be reverted to a previous version, I would appreciate it @PoshKiwi.

1 Like

I have been reverted back to the new unstable build and based on what previous people said, I assume this is the patch that was meant to fix things. However, the opposite has happened and nothing changed from when I originally reported this issue. Could I be put on the old build again while this is fixed? @PoshKiwi .Thanks!

Also my nvidia drivers are on version 516.94 (the latest).

1 Like

It still crashes when applying script edits or the inert object menu is opened. It’s been 10 days!

Highly likly at this is due to the new Roblox Desktop update. Run studio as administator

I’ve had the desktop update for a decent while now, and my issues started like 3 days after this post, so I don’t think so
(assuming your talking about the roblox desktop app that you can disable by running roblox as an administrator)

Im also having this issue, every time I try to open the object browser, my roblox studio crashes! Its really annoying.

Whatever you do, do not do this at all. This will require Roblox Studio to always be run as administrator and won’t be able to open using the shortcut!

This is something I experimented with and I can confirm this is something to avoid.

@PoshKiwi I found out that opening Roblox Studio again after one is open allows both to not crash at all when opening the menus. It also keeps working if you close the second one. It had nothing to do with letting Roblox Studio sit. It seems to be a loading issue with assets from the looks of it and because a second one is opened, it allows the rest of the assets to be loaded into memory.

Edit: This is a consistent workaround. I did several tests doing this and it works! You have to let the first Roblox Studio crash while the other one is open and it should be all good to go. You’d have to do this every time you open Roblox Studio if it is not already open in a separate window.

Video on the fix:

3 Likes

My studio client was updated back to the version that crashes and the issue was reintroduced for me. I will have to try this! Thanks for the tip.

Please give us a stable version of Studio. Roblox team released this update prematurely and has caused numerous issues for numerous people…

1 Like

I just want to say that a possible temporary solution is to revert studio yourself. You can use this using CloneTrooper1019’s studio mod manager utility. You can force a certain version to be used (date based) which is really useful. This has worked for me until Roblox actually makes studio stable again.

1 Like

Using a 3rd-party application to allow for earlier versions is a solution, but using my weird method allows you to use the most recent version without the issues or 3rd-party apps.

Edit: The mod manager is not really a good idea if you want to be able to use the most recent features that the version of Roblox Studio that crashes provides, like the updated collision groups.

1 Like

Welp, the previous workaround doesn’t work for me anymore after an update, and now I can’t use Roblox Studio properly anymore. I am unsure if Roblox has this at a high priority right now and if Roblox even has a way to figure this issue out in any way possible.

1 Like

I don’t know if this is the same issue, but the new forced Roblox beta app also crashes just like Studio when I tried to go to messages in settings.

EDIT: I recently opened Roblox studio and it had an update. I DO NOT KNOW IF THIS FIXED THE ISSUE ABOVE OR THE CURRENT ONE.
Edit 2: Roblox beta app crashing is fixed, but one thing to note; when not in-game on the beta app, the cursor will freeze along with the fps. This doesn’t take place in the website-launched player. Roblox studio still has the same issue.

I never had the issue with the desktop app, but I can only assume it might be related to the same issue