Cannot open roblox studio

Hey I think I fixed it
What I did was delete the roblox folder and then open studio in administrator mode

Check if the firewall is blocking roblox servers, Looks like http send request failed is that they can’t reach their servers

Was able to find a workaround for a few days but then the workaround stopped working and I cant open it again please help


I noticed that studio ran fine when I downloaded & used it while signed into a different roblox account, but when I tried opening studio by clicking edit on a game that was on this account it stopped working

I think there are some settings that are associated with this roblox account that are corrupted so when I use studio with this account it doesn’t work

I can’t make new topics here, but I’m also having a really difficult Studio Bug.

I did get the error you mentioned just earlier, but most of the time it hangs/stops responding before it actually opens.

After a fresh installation, deleting anything related to Roblox from my computer, I seem to sometimes have access for a single session, but sometimes it also crashes and freezes there.

I’ve tried to/completed:

  • Restarted computer (many times)
  • Reinstalled Roblox (20+ times)
  • Uninstalled > Removed Local App Data Roblox folder > Removed additional shortcuts and anything Roblox related and reset cookies and internet data > Restart > Reinstall based on this guide (occasionally after this step I could open 1 project, but it would still stop responding at some point soon after.) (10+ times)
  • Turning off my firewall and ensuring accurate proxy settings based on this guide (many times)
  • Started Roblox via the RobloxStudioBeta.exe -disableLoadUserPlugins command based on this page (5+ times)
  • Reset my PC to a previous snapshot/backup when Studio had worked (1 time)
  • Tried to launch Studio through this page based on this forum post (5+ times)
  • Deleted Roblox registry values in HKEY_CURRENT_USER > SOFTWARE (after this, a restart, and a fresh installation I could open two projects, but it failed again after I left my computer for ~an hour)

Make sure your proxy or ISP is not blocking any internet connections. I had the same issue once, but I solved it by connecting to the internet.

Same bruh I tried all of that and It still didn’t work let me know if you find a solution tho

1 Like

Hey I’ve been completely unable to open roblox studio or roblox player for the past two days & have tried everything on my end to try to fix it, I would appreciate if someone could look into this please

I believe I’m also encountering this issue. Starting from this morning, I have been unable open Roblox Studio at all on Mac OS, receiving this message whenever I attempted to open it:


Reinstalling did not fix the issue. If it’s of any relevance, yesterday I finally received the studio overhaul with the new icons and docking, which massively tanked my FPS in the script editor and game window. (not playtesting)


Change your G-Sync settings.

My iMac does not support G-Sync.

Still having problems opening studio please help

1 Like

I’ve been experiencing problems for a while now. Unlike @indieun_X, studio is not giving me errors, just not opening.

Been happening for over a week. Start time about the same time that @indieun_X reported the error (I assume studio launched an update at this time).

I’ve posted in other related bug report threads, to no avail.

Studio was reverted for a while (thanks to @PoshKiwi, I believe), but studio just updated. I’m once again left facing the bug. No errors, just a frozen white screen whenever I attempt to open studio.


@Infinite_Visions (and @indieun_X) I think I had the same issue as y’all.

Support suggested I make a new Windows account. I followed the instructions here and that seems to be the best solution I’ve had so far. It’s worked stably for three or four hours and a few times leaving my computer. Previously everything else I changed failed before that.

Worth a shot if you haven’t done that yet.

Here’s something else worth trying:

Go to regedit and go to the path Computer\HKEY_CURRENT_USER\SOFTWARE\Roblox\. Delete the RobloxStudio keys. Your problem might just be fixed.

If that doesn’t work, navigate to %temp% and delete everything you can in the directory. Then, delete everything from the Roblox directory in %localappdata%. Reinstall Roblox, and your problem might be solved.

This worked for me for a previous UI issue I had. It’s worth a try here as well.


Appreciate the tips!

Tried deleting those, and the issue was still not resolved. Unfortunately, my studio just bricked itself on the new account as well. Any clarity or ability to fix this, so I don’t have to add/delete users from the PC/Windows Account level would be great.

It seems to happen if I walk away from Studio for (some) amount of time, and it loses connection to (something) and then can’t recover.

I’d make a new post, but I still don’t have access to this forum, sorry about the bump.

What exactly is the error message, if applicable? If there isn’t an error message, it is most likely the white screen of death issue.

There was another topic about this recently in #help-and-feedback:platform-usage-support and it has not been solved yet, so I’m currently wondering how to fix the issue myself and I can’t reproduce it either.

Try launching studio by running RobloxStudioBeta.exe instead of RobloxStudioLauncherBeta.exe.

1 Like

Hey @SubtotalAnt8185 , it is in fact that “White Screen of Death” issue, and what’s documented in the other thread. Last time this happened, it was resolved when I made a new account, but I’ve gone through torching everything and restarting twice now, and it’s not working this time.

I’ll see if deleting absolutely everything, the other user account, and running it from that launcher the first time fixes it for me.

1 Like

@SubtotalAnt8185 Alright, so, it’s working again temporarily at least, and what I did was:

  1. Totally uninstall every file, temp file, delete every registry key in SOFTWARE for Roblox/Roblox Corporation. (Uninstall via Windows add/remove applications > delete contents of AppData\Local\Roblox > delete registry values.
  2. Delete the Windows account where Roblox failed.
  3. Restart the computer.
  4. Create a new Windows Account.
  5. Install Roblox Studio on a brand new Windows account (it automatically launches)
  6. Exit before logging in.
  7. Go to the temp/local folder, and run the RobloxStudioBeta.exe from there
  8. Open a game place.
  9. Then I just ran around a world a bit, clicked “play here”, played, saved, and exited.
  10. Closed Studio and reopened, and it did not give me the white screen of death.

Temporary disclaimer: last time I was dealing with this issue it could resolve for a single session, but when I returned to my computer “later” it would have ceased to work. I’ll follow-up again if it’s still working later tonight/tomorrow.

1 Like

Hi all, typically these errors indicate a service outage or some other type of site event. We’ve upgraded some of that messaging in the past few months, but its still possible in some cases to see something like this. Generally resetting accounts or clearing registries should not be necessary, but if you are ending up in something like this, please respond back here. Thanks!