Studio Explorer Menu Dropdowns Take Forever to Load

The explorer menu in Studio takes forever to drop down and view an instance or service’s descendants. This only started this afternoon after the most recent Studio update and I already tried restarting Studio. I have attached a video:

  • Sidenote: drop downs that worked instantly were ones I had clicked ~1 minute before the video started


  • Open a .rbxl file or edit a game
  • Open the explorer menu
  • Click any dropdown

I’m on MacOS Mojave 10.14.6

I was just about to get into some intense coding but I have long hierarchies that need to be viewed in my explorer and I can’t write the code without being able to use these dropdowns.

1 Like

Have had this issue before, don’t know what’s up. I’m on an iMac so maybe that’s the issue :man_shrugging:


Thanks for the report. Does this happen with a new place (Baseplate for example)? I’m trying with the same MacOS version and am unfortunately not seeing this behavior.

This happens to me rarely, and it is random and hard to reproduce. What I do to fix is to restart studio.

@tamtamchu Fortunately, I am unable to reproduce now. Upon restarting a second time, the delay for the dropdown was gone.

@tamtamchu Unfortunately this is reoccurring at random in Studio. About one out of every dozen times I get this behavior and it’s not fun and I end up having to restart my test session or Studio to get proper functionality back. :frowning:

I am on Windows 10 and this has happened to me before. Very rarely and when it does happen it only happens on one menu dropdown.

I am also on macOS Mojave 10.14.6.

I get this issue sometimes when I’m using “Future” lighting. The explorer menu takes a while to drop down if my camera is actively looking at a spot with lots of lights, but loads fine once I move away. The entire issue goes away when I switch back to one of the other Lighting methods.

Other times, without “Future” lighting, this issue seemingly occurs at random when I’m in the “Play” test mode in Studio. I’m assuming Studio is choosing to prioritize the game graphics over the drop down menu?