Studio FPS drops whenever I move a part, regardless of how many parts are in the place

This is an issue that has been happening to me for a long time, the first time I got this, I fixed it just by clearing some space on my computer, but now I see nothing that could make studio lag so much

As soon as I move a brick, it’s like my whole computer dies (apparently it affects my whole pc too), and it happens all the time

It happens to me in any version of Studio, also happens in a default baseplate.
Changing my graphics mode doesn’t help the issue.

I’m not using packages.

Microprofile dump: microprofile-20191227-024625.html (2.8 MB)


not moving


My specs:
CPU: Intel Core 2 Duo E8400 @3.00GHz 3.00 GHz
Graphics Card: Radeon RX550
Idk what’s my motherboard, if that’s also necessary

I have 27.1GB of free space of 148GB

It looks like Present and Scene are abnormally long. computeLightingPer and Shadows make me think it could be lighting related? Your “default baseplate” doesn’t look anything like the default baseplate lighting-wise either:

It’s possible a plugin is dialing lighting effects up to 11 on your machine. Could you disable all plugins, create a new place, and see if the problem persists?


Looks like that really was the problem, I disabled the plugins and now I can move parts and the camera with no problem at all, thank you so much

(btw, the screenshots used in the post aren’t from a default baseplate, but I tried moving a part before in a default baseplate and I had the same results)

If you gradually re-enable plugins until you figure out which one it is, it may be worth giving the plugin author a heads up so they can fix it, and/or posting a link here in case others experiencing the same issue find your bug report and can check if they have the same plugin installed.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.