Studio FPS tanks while moving cursor

Reproduction Steps

I can reproduce this by simply opening a new baseplate file and moving my cursor. All beta features are disabled.

System Information

Description Details
Processor Intel(R) Core™ i7-8700 CPU @ 3.20GHz
Graphics NVIDIA GeForce RTX 3070
Installed RAM 64.0 GB
System type 64-bit operating system, x64-based processor
Pen and touch Pen support

Windows Information

Edition Windows 11 Education
Version 22H2
Installed on ‎9/‎13/‎2022
OS build 22622.598
Experience Windows Feature Experience Pack 1000.22634.1000.0

Additional info

  • This report was generated on NVIDIA Game Ready driver 512.77, but it still happens after updating to 517.48.
  • I run a dual GPU setup, 3 monitors; 3060 Ti powers two of them and the 3070 powers my main screen. I’ve tried on both GPUs and it happens on both.
  • I tried closing all other applications, issue remained
  • I tried disabling all plugins, issue remained

Expected Behavior

When moving the mouse cursor, my FPS should not be affected. Also, while holding RMB and moving my mouse at a consistent speed, I expect the camera to move at a consistent speed, regardless of FPS.

Actual Behavior

Here’s a microprofiler dump of me getting the framerate down to 1fps just by moving my mouse: microprofile-20221011-215526.html (2.9 MB)

Issue Area: Studio
Issue Type: Performance
Impact: Moderate
Frequency: Constantly


you might have an unperformant plugin installed

Great suggestion!
I just tried disabling all my plugins and restarting studio, but unfortunately the issue persists.

Maybe try to downgrade / rollback to old version of your NVIDIA Driver, This is what happend after I updated my NVIDIA Driver but after rollback to old version everything is working fine.

I’ve been having the same issue with studio. The only way I could find to fix it was to drag the baseplate tab off studio itself. However, now whenever I want to, for example write a script, I need to either put the tab back or move it out of the way or resize it to see the script.

Can you let me know which driver versions you’ve tested on where it did and didn’t work properly? I have tried two versions (mentioned in my post, NVIDIA Game ready driver 512.77 and 517.48) but it happens on both.

My NVIDIA Driver version is 511.79 btw, It happend in August 2022 my Roblox Studio is completely broken after updating NVIDIA Driver Studio yup its so laggy just to moving around on my Roblox Studio and many unknown light from the studio, Then I rollback the update it work fine and gone. Hope your issue got fixed dude.


This issue also happens for me, but for 2 seconds only when i drag a studio widget. Its really annoying but if i normally move my cursor without dragging any studio widgets, its fine

Hi, thanks for the report. I am unable to reproduce this issue on my end. Are you still experiencing this?

This does indeed still happen for me, currently on studio version 549.

Is this older one still reproducible? Let us know if it is. Thanks.

Hi all, sorting through some older issues - we’ve yet to find a consistent repro for this one that points to something other than driver HW issues, but if you are still consistently experiencing this on baseplate, can you please reply here?

Thanks for checking in. I am no longer experiencing this bug! Both of the issues mentioned in my report seem to be gone.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.