Studio freezes when trying to view Sound's Preview property


#1

Last night, I noticed that Studio freezes 100% of the time when trying to view a Sound’s preview property, and I know it’s specifically that. I can view the other properties of a Sound above Preview, but as soon as I scroll down to it Studio freezes. I get the same result if the Properties window is already expanded to view all properties. I re-downloaded Studio but it continues to happen.

The Preview property has given me a lot of trouble up to now, I believe it’s responsible for causing lag in relation to how long the object is selected (mainly its properties being viewed).


Sound Instance Causing Crashing on Mac
#2

Hi dragonfrosting, thanks for the report. Which platform does this occur on? Does it occur while editing, or only during Play or Test/Start?


#3

I’m experiencing this on an iMac running High Sierra (10.13.5). It also occurs during play tests, basically at any point that Studio tries to display the Preview property in the Properties window.


#4

Im am also experiencing issues on High Sierra.

  1. Open Studio
  2. Run from the command bar while in Edit Mode:
    Instance.new("Sound", game.SoundService)
  3. While still in Edit Mode, select the new Sound from the explorer window
  4. Studio will hang for what seems to be indefinitely

#5

I’m also experiencing this, can’t even click on the Sound object though. I’m on High Sierra.


#6

I’m also experiencing this, has to drop the sound file outside of its current parent, then put it back. Doesn’t allow me to even select the object without freezing. I am on macOS Mojave (10.14)


#7

I’m also experiencing this. Have been having to edit sound IDs via the command bar.


#8

I’m also experiencing this, studio crashes whenever I scroll down the sound properties. I’m on macOS Mojave.


#9

I have started doing this to deal with sounds in the meantime, I am hoping it will help others:

  1. Close the Properties Window
  2. Select the sound
  3. Type this into the command line, modify it as needed and hit enter:
local Selection = game:GetService("Selection")

for _, object in pairs(Selection:Get()) do

object.SoundId = 1911995155 end

Edit: Although this worked at the time I posted this, for some reason it no longer works. I’m sorry.


#10

This has started happening to me over the past week or so, and even before then playing sounds from the properties window or entering new sound IDs would cause studio to freeze. I use the command line to add and edit sounds but it’s time consuming.

Edit: I’m also on macOS High Sierra


#11

This is still happening for me too. I am also using mac.


#12

I’m also suffering the same conditions. Stage fright like this makes changing sound effects very much painful. I hate resorting to a low-end windows laptop for small things.

I also have issues with the color3 popup menu, in addition to the numbersequence popup menu. Perhaps these are related?

I am running macOS Mojave (10.14)


#13

Yes number and color sequences for particle emitters haven’t worked on Mac for me either for many months. I think Mac support is a much lower priority than Windows support which sucks but I guess I can understand. If you close the properties window and then insert a sound (with that window closed) that will work, but you cannot edit it and will have to use a script to make your changes. That is what I do now.


#14

I think that if you offer any application on more than one platform, you have to commit to each version’s compatibility. Just imagine having one machine that runs macOS, with a relatively successful game, only for it to tank because you can’t update the game as fast as before, as a consequence to these bugs.


#15

I agree completely and I am honestly really frustrated that these issues appear to be unaddressed. I am saying “appear” because I know that the people at Roblox work incredibly hard every day and I do not think they do not care, I think they are just too busy. I really hope they will make these fixes soon so us Mac users can take full advantage of the excellent platform Roblox Studio provides. It is disheartening, however, that after almost a full year, the usability of the aforementioned features have only deteriorated.


#16

I would like Roblox to have a debugging team, or branch of a team if it already exists, that specifically pokes at the latest update the engineers are cooking on the latest version of macOS. It just feels like an untold necessity.

One thing that I think might be the cause of these issues, is the recent changes to the Toolbox. Maybe there’s something that Studio is looking for that the old Toolbox had, but the new Toolbox doesn’t, thus causing stage fright? :man_shrugging:

The sooner these issues are mentioned as fixed, the merrier I am.

Edit: I am currently running Studio on 364, and this issue (to my knowledge) is not fixed yet. No release notes have been uploaded to the forums yet.


#17

Yup. Still broke for mac. Also have crashes with color sequences for particle emitters :disappointed_relieved:


#18

Following up, it seems this issue has been resolved for me on my end. Feel free to confirm


#19

Yeah, I’m going to go ahead and mark this as resolved.


#20

I, too, can attest that the bugaboo has been dealt with.

:clap: :clap: :clap: