Studio frequently crashes seconds after Play Testing

The same thing has been happening to me lately too. Although for me, I think the freezes only occur after I stop a play test. I don’t get the crash message either - studio just freezes up forever.


Hi, the link to the .DMP file seems to be not valid?

1 Like

You need to have a co-worker add you to this devforum group, then you can access it: Logs / crash dumps / other bug files - Developer Forum | Roblox

1 Like

i have same graphic card and it also happens to me

I seem to be having the same bug, not my graphics driver, is it maybe an item in roblox studio that involves this crash?

I’m also experiencing these crashes (with “An unexpected error occured and Roblox needs to quit” popup 100% of the time) ever since I bought a new laptop a few months after this thread went inactive.

It gets to a point where it can crash every time I try to playtest consecutively. I’ve also experienced crashes on Studio without going into playtesting as well as on the client. I tried multiple solutions to fix it, reached out to Roblox Support about it with no luck, and even wrote a thread on it.

Here are my specs:

Processor 11th Gen Intel(R) Core™ i5-1135G7 @ 2.40GHz 2.42 GHz
Installed RAM 12.0 GB (11.7 GB usable)
Product ID 00325-97233-31051-AAOEM
System type 64-bit operating system, x64-based processor

I never remembered a time where Studio crashed so many times on my older device.

Having the same issue! Need immediate help!

Happens to me too my specs are

Ryzen 5 4000 series
8GB Ram
GTX 1650 4GB

It was randomly freezing at first after recent update and seems to be in connection with direct3D11 render. But then it stopped now it just freezes 100% when I try interacting with a pickup item for my inventory system. It only freezes in studio but in game it works. I created an empty project and as I was placing parts I got a message that it needed it close. Roblox studio has completely become unusable all in just one update for me. I was working on my game for 4 months and now I have to find something else to do with my time as I cannot dev like this and im only getting pre made response from Roblox looks like my dev journey is over because im just a small person


It’s not my project it’s just Studio in general. It will crash or just get hung up forever. Sometimes it shows this message sometimes it just hangs.

Same thing happening to me, its making it super hard to create a game because everytime i test it, there is a 50/50 chance I crash


This may not help your case but, I was having the same issue. I uninstalled and reinstalled studio, again this may not help but it worked for me.

I have a similar issue, except it seems to only happen in one game. Upon attempting to playtest, it immediately crashes with no errors or warnings, closing the window immediately.

This is the place that causes a crash on Studio for some reason. All other places do not crash however, local-stored or cloud-stored. This place doesn’t crash on the player though, so I dunno what’s happening here.

Does any roblox employees or experienced developers know what’s causing this similar crash?


I’ve had the same problem for a long time and it keeps repeating itself every time I test the game and I’ve lost patience :expressionless:

This is suddenly happening to me too. The weird thing is it only affects either the quick access play button or the one under the Test tab, usually the quick access. If I remove the play button from quick access it begins crashing when I use the Test tab instead. Otherwise the Test tab works fine.

1 Like

It is happening to me too. Sometimes it crashes after a 2nd playtest, a 3rd or even the 1st one. It is hella annoying and i can’t do much about it.


It seems to be fixed for me now. I got a random CSG error out of nowhere when I opened my place and the crashing is gone.

This is the exact position I’m in, any fix?

1 Like

Me too I’m crashing like crazy

It keeps giving me bad allocation and freezes my screen for like a good minute

Sometime it would shut down my PC off


I’ve been having this issue, but it freezes my PC, I’ve tracked it down to a memory leak

Anyone knows what’s happening?


Same this happens to me every time I try to run a test server



Yep, this exact problem. Started happening after the update around 1-2 PM CDT, I can’t submit bug reports for some reason unless you’re able to?