Studio games won't publish

Hey, I’ve been developing for a while now and it happened to go okay until I ran into this problem. In Roblox Studio, any game/place I create/edit just won’t publish or update, no matter how much I try. I just don’t know what has happened, when I press the create button for publishing places, it just greys out for a while then turns back to normal and repeats when I press it again. The same thing happens when updating a game.

I tried re-installing studio but the same problem happens and it didn’t help. I’m probably the only one with this problem, and I just don’t know what to do now.


This never happened to me before.

Maybe it’s because of a max place limit.

I would not know any fixes yet, although I have a workaround if you’re not at your max places yet:
For the workaround you have to use the “Create” part on the website. Under games click “New Game”, click your desired template, change the settings of the game at the tabs above and then “Create game”.

Then after that just click “Edit” next to the game. In Studio use File>Publish To Roblox to publish your changes.

EDIT: If my response was useful and helped, then consider marking it as answer, this will help people in the future fixing possible the same issue more easy.

1 Like

Oh wow, this is very helpful and did help me, thank you :+1:.

1 Like