Studio is capped to 30 fps but nothing else is

I wasn’t able to post on the Bug Report category so I posted it here.

For the past 2 days, Roblox Studio has been dropping frame rates on me, and it’s so noticeable that it bothers me. What I find strange is that playing a normal Roblox game with the Roblox Player and using my web browser runs perfectly fine with 144 fps, but compared to playtesting and using studio normally, it’s very laggy, and my inputs are sometimes slow.

First, I tried restarting my PC, but the issue persisted. Then, I tried setting my frame rate down to 60, but nothing changed again. Then, I tried disabling and reenabling my fps unlocker, but the issue persisted again. I couldn’t think of any other ideas on how to fix this issue, so I’m using this forum as a last resort.

System information:

  • OS: Windows 11 Home
  • Processor: 11th Gen Intel(R) Core™ i5-11500 @ 2.70GHz, 2712 Mhz, 6 Core(s), 12 Logical Processor(s)
  • GPU: GeForce RTX 3060

This seems very interesting. If you run the command in chat /console while in studio, the client is always using a truckload more memory than the Roblox Player. But seeing as how it wasn’t always like this, I recommend that you delete studio, do a hard restart of the computer, and re-install. If the error continues, please contact me.

Send a message to this group to file a bug report: Bug support - DevForum | Roblox

I unplugged my PC for 2 minutes and reinstalled Studio after. My fps and my input speed are a bit better now, but my fps is locked at 30 fps. I tried turning on and off my fps unlocker, but nothing changed. Do you have any other solutions I can try? I appreciate the response.

I’m really not sure - sometimes (though vary rarely) GPUs can be affected by a build up of dust. Maybe try checking your tower/laptop for dust?

  1. I just got this PC one day before Studio started kinda lagging.
  2. It’s fps is 30 only for Studio.

Update: BlueStacks 5 is refusing to boot up no matter what instance or version I’m on. It might be associated with Roblox Studio’s issue as well. It could be a setting that I might have accidentally turned off or on.

:sweat_smile: Finally got it back to 144 fps after a week! I think I tampered with the Nvidia Control Panel settings a bit much. I simply had to restore my settings to default. I just gotta fix BlueStacks 5 as well cuz it still doesn’t work.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.