Studio is dragging map objects when focusing back on the Studio window

Hoping to see a patch soon! :heart:

This began happening today. Simply click on a window outside of studio, then click back into studio. Studio will randomly drag parts of your game. If you’re not paying attention, this can really damage your map with no way to undo the damage.


This clip showcases all three issues happening in a row.
1st, a selection box. No big deal.
2nd, dragging a building roof. Bummer!
3rd, dragging entire models, like all of our skyscrapers!

I’m running macOS 10.15.3 on a 2013 Mac Pro machine. Not sure if this is also a problem on Windows. Thanks!

19 Likes

Doesn’t seem to happen on windows.

Yeah, I get this the whole time. I’m also running a Mac. The only solution I’ve found is to restart studio.

1 Like

I’m running on macOS and I’ve had the same issue lately.
It seems like the center of the window gets offset sometimes for some reason.

Does it actually bypass the history service and prevent undo action from functioning properly?

Hey asimo,
thanks for letting us know about this issue. We are looking into it.
Can people experiencing the issue let me know if they have the Lua Draggers Beta enabled?

I do have the Lua Draggers Beta enabled.

Here’s a shot at the bug I’ve just recorded.

1 Like

This doesn’t look related to this bug report?

1 Like

Does it actually bypass the history service and prevent undo action from functioning properly?

My problem is I’ll end up dragging something without noticing. Once I save and exit, I’m doomed. I’ve made myself more aware about clicking into studio now though, I’m not as worried.

I do not have lua draggers enabled. These are my enabled Beta features.

2 Likes

This has something to do with the new tools of roblox. I get this glitch to (and they edited the selection tool)

That’s for another topic then. The video shown above by @gui110 is just a dragger bug. This topic is about studio auto-clicking for you.

1 Like

You do “have the beta on”, it’s just not a beta anymore as you’ve been force enrolled as part of the release. Sorry for the miscommunication there.

That’s interesting because I didn’t turn on any dragger flags yesterday, only on Tuesday. Did you use studio on Wednesday at all and not have an issue then?

I tried a cursory test of behavior on my mac and can’t repro this. Here’s what you can help me with:

  • Are you on mac? (It seems like this is a mac only issue from the current responses, but I want to double check)

  • Are you using mouse or trackpad to work? Do you alternate between them?

  • Are you using the touch device emulation features of studio at all in the sessions where this occurs?

  • Some of you mention restarting studio. Is this a transient issue that comes and goes, or does it happen always for you? Have you noticed any patterns about the frequency of it occurring if it is transient?

  • Could you try disabling all plugins and see if it still occurs? (I don’t expect it’s a conflict with other plugins, but I want to make sure)

We will consider reverting the Lua Draggers back to beta if we can’t figure out what’s going on with this issue by end of day.

I’m not sure if it’s related to what @asimo3089 mentioned but I also have this selection box bug when clicking outside of the Studio window and then back in studio creates an unwanted selection box…

We’ve identified the root cause of this issue and canceled the rollout until a fix has shipped. You can still access the Lua Draggers through the beta features panel if you want them until then.

1 Like

This has happened to me a a lot, but I was able to undo mine.

I’ve tried to make the bug happen, it didn’t seem to happen.
I’m running macOS 10.15.6 on a 2017 Mac.

I’m having this on Windows 10 ver. 1909. My device is well-speced with an Intel Core i5-8400H and 8gb of RAM.

It doesn’t happen one windows, however, have you tried ctrl-z? That might work.