Studio login broken

I just clean-installed Windows 10, installed the latest versions of the ROBLOX Player and Studio, and logging in doesn’t really work in Studio. The start page says the login is successful, but if I refresh it, I’m no longer logged in. If I try to load one of my places, I get “script signature failed” because I’m not really logged in. I’ve tried uninstalling / rebooting multiple times. If I try logging in with the wrong password, it won’t let me, so I know it’s verifying the password at the very least. There’s nothing in the logs (%localappdata%\Local\ROBLOX\logs) to suggest anything’s wrong either.

Edit: Whenever I try to play a game, it tells me to install ROBLOX (even though it’s already installed) I’m also not having this issue on my laptop which I also just clean-installed Windows 10 on.

Edit2: Tried everything on this page, but no dice

I also don’t see the ROBLOX Launcher in Firefox’s plugins:

Maybe ROBLOX isn’t able to install correctly for some reason? I’m running the installer as an administrator, so I wouldn’t think it’s running into permission issues.

One of my friends has been having this problem too. He’s on a MacBook, I don’t think he was trying to reinstall anything.


Okay, turned out it was two separate issues.

Issue #1:

I installed a 64-bit version of Firefox and the ROBLOX launcher plugin (at least for Firefox) is 32-bit and can’t be used on the 64-bit program. I had actually run into this issue a while back when I tried using Waterfox (64-bit copy of Firefox), so when I noticed Firefox was 64-bit, the issue clicked.

Issue #2:

I don’t know? But logging into ROBLOX from the Edge browser, playing a game, and then opening studio fixed the problem. I’m now able to log into studio properly. Note: I did this before switching to 32-bit Firefox, so I don’t think issues 1 and 2 are related.

1 Like

Sounds like some sort of read write error. 64 bit Firefox/waterfox have worked fine for me without any sorts of issues. So uh… It’s m that is honestly weird.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.